summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThijs Kinkhorst <thijs@debian.org>2013-06-10 19:50:09 +0200
committerThijs Kinkhorst <thijs@debian.org>2013-06-10 19:50:09 +0200
commitf41083924037e69f2b4d37c783a9fe7433777b50 (patch)
treeb63fdbe33a7ea71dcdb6545a9b20f5b89d204112
parentea93bfa0f9361f15071075c4982a4ee4232bd906 (diff)
downloadca-certificates-f41083924037e69f2b4d37c783a9fe7433777b50.tar.gz
Drop upgrading code for upgrades from Debian Etch and earlier.
-rw-r--r--debian/changelog4
-rw-r--r--debian/config.in72
-rw-r--r--debian/postinst3
-rwxr-xr-xdebian/rules4
4 files changed, 11 insertions, 72 deletions
diff --git a/debian/changelog b/debian/changelog
index 80f0878..f80910c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,6 @@
ca-certificates (20130508) UNRELEASED; urgency=low
+ [ Michael Shuler ]
* TODO: NEWS entries, https://bugzilla.mozilla.org/show_bug.cgi?id=850003
* Install CAcert root and class3 certificates individually, no longer
installing the concatenation of the two. The individual certificates
@@ -15,6 +16,9 @@ ca-certificates (20130508) UNRELEASED; urgency=low
* Update to machine-readable debian/copyright file v1.0
* Clean up man page (LP#: 850997).
+ [ Thijs Kinkhorst ]
+ * Drop upgrading code for upgrades from Debian Etch and earlier.
+
-- Michael Shuler <michael@pbandjelly.org> Wed, 15 May 2013 11:57:18 -0500
ca-certificates (20130119) unstable; urgency=low
diff --git a/debian/config.in b/debian/config.in
index 456dd36..8885f30 100644
--- a/debian/config.in
+++ b/debian/config.in
@@ -4,9 +4,6 @@
set -e
action="$1"
-cur_version="$2"
-this_version='#VERSION#'
-pt_BR_fixed_version="20080616"
if test -f /etc/ca-certificates.conf; then
CERTSCONF=/etc/ca-certificates.conf
@@ -122,9 +119,6 @@ if db_get ca-certificates/enable_crts; then
fi
new_seen=false
-if dpkg --compare-versions "$cur_version" lt 20040808; then
- db_fset ca-certificates/new_crts seen false
-fi
if db_fget ca-certificates/new_crts seen; then
new_seen="$RET"
fi
@@ -158,66 +152,12 @@ fi
# mark seen true, so that dont ask again while postinst
db_fset ca-certificates/new_crts seen true
-# Ideally, we would be able to ask debconf for the language it's using, or
-# at least have a shell binding for setlocale(). Since we don't, we have to
-# do it all by hand.
-is_pt_BR () {
- current_lc_messages="$(eval `locale`; echo "$LC_MESSAGES")"
- case "$LANGUAGE" in
- pt_BR*)
- return 0
- ;;
- *)
- case "$current_lc_messages" in
- pt_BR*)
- return 0
- ;;
- esac
- esac
- return 1
-}
-
-PRIO=low
-set_values=true
-
-if dpkg --compare-versions "$cur_version" lt-nl "$pt_BR_fixed_version"; then
- asked="false"
- if db_fget ca-certificates/enable_crts asked_pt_br_question; then
- asked="$RET"
- fi
- if [ "$asked" != "true" ]; then
- if [ -e "/etc/ssl/certs/ca-certificates.crt" ] && [ ! -s "/etc/ssl/certs/ca-certificates.crt" ]; then
- pt_seen="false"
- if db_fget ca-certificates/enable_crts seen; then
- pt_seen="$RET"
- fi
- if [ "$pt_seen" = "false" ]; then
- CERTS_ENABLED="$CERTS_AVAILABLE"
- elif is_pt_BR; then
- PRIO=critical
- CERTS_ENABLED="$CERTS_AVAILABLE"
- seen=false
- else
- seen=true
- fi
- fi
- else
- set_values=false
- fi
-fi
-
-if [ "$set_values" = "true" ]; then
- db_set ca-certificates/enable_crts "$CERTS_ENABLED"
- db_subst ca-certificates/enable_crts enable_crts "$CERTS_AVAILABLE"
- if test "$seen" != true; then
- db_fset ca-certificates/enable_crts seen false
- fi
- db_input $PRIO ca-certificates/enable_crts || true
- db_go
-
- if [ "$PRIO" = "critical" ]; then
- db_fset ca-certificates/enable_crts asked_pt_br_question true
- fi
+db_set ca-certificates/enable_crts "$CERTS_ENABLED"
+db_subst ca-certificates/enable_crts enable_crts "$CERTS_AVAILABLE"
+if test "$seen" != true; then
+ db_fset ca-certificates/enable_crts seen false
fi
+db_input low ca-certificates/enable_crts || true
+db_go
exit 0
diff --git a/debian/postinst b/debian/postinst
index f6ace52..6b24d9b 100644
--- a/debian/postinst
+++ b/debian/postinst
@@ -58,9 +58,6 @@ case "$1" in
CERTS_ENABLED="$RET"
# XXX unmark seen for next configuration
db_fset ca-certificates/new_crts seen false
- # We should clean up this value now, as everyone will have
- # upgraded to a fixed version.
- db_fset ca-certificates/enable_crts asked_pt_br_question false
db_stop || true
if test -f /etc/ca-certificates.conf; then
# XXX: while in subshell?
diff --git a/debian/rules b/debian/rules
index 129ac90..7438471 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,8 +5,6 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-VERSION := $(shell dpkg-parsechangelog | sed -ne 's/^Version: //p')
-
configure: configure-stamp
configure-stamp:
dh_testdir
@@ -56,7 +54,7 @@ install: build
fi; \
done; \
cd $(CURDIR)/debian; \
- sed -e "s|#INITIAL_CERTS#|$$crts|" -e "s|#VERSION#|$(VERSION)|" \
+ sed -e "s|#INITIAL_CERTS#|$$crts|" \
config.in > config)
# Build architecture-independent files here.