summaryrefslogtreecommitdiff
path: root/mozilla
diff options
context:
space:
mode:
authorMichael Shuler <michael@pbandjelly.org>2015-10-22 17:06:09 -0500
committerMichael Shuler <michael@pbandjelly.org>2015-10-22 17:06:09 -0500
commit9ec192590b11474ae96f9fedadbe585a5805adc3 (patch)
tree90f9d75f780f57d8dbbcac185ad6b739dea17e77 /mozilla
parentb44346ada88584012929fb08e8d1222cc6a101c7 (diff)
downloadca-certificates-9ec192590b11474ae96f9fedadbe585a5805adc3.tar.gz
Revert "Add Python 3 support to ca-certificates."
This reverts commit a2fa9a13815894500e1e2d9ca3d52bfdd4f75b5a. Conflicts: debian/changelog
Diffstat (limited to 'mozilla')
-rw-r--r--mozilla/certdata2pem.py32
1 files changed, 13 insertions, 19 deletions
diff --git a/mozilla/certdata2pem.py b/mozilla/certdata2pem.py
index ec48ab6..0482894 100644
--- a/mozilla/certdata2pem.py
+++ b/mozilla/certdata2pem.py
@@ -53,7 +53,7 @@ for line in open('certdata.txt', 'r'):
if type == 'MULTILINE_OCTAL':
line = line.strip()
for i in re.finditer(r'\\([0-3][0-7][0-7])', line):
- value.append(int(i.group(1), 8))
+ value += chr(int(i.group(1), 8))
else:
value += line
continue
@@ -70,13 +70,13 @@ for line in open('certdata.txt', 'r'):
field, type = line_parts
value = None
else:
- raise NotImplementedError('line_parts < 2 not supported.')
+ raise NotImplementedError, 'line_parts < 2 not supported.'
if type == 'MULTILINE_OCTAL':
in_multiline = True
- value = bytearray()
+ value = ""
continue
obj[field] = value
-if len(obj) > 0:
+if len(obj.items()) > 0:
objects.append(obj)
# Read blacklist.
@@ -95,7 +95,7 @@ for obj in objects:
if obj['CKA_CLASS'] not in ('CKO_NETSCAPE_TRUST', 'CKO_NSS_TRUST'):
continue
if obj['CKA_LABEL'] in blacklist:
- print("Certificate %s blacklisted, ignoring." % obj['CKA_LABEL'])
+ print "Certificate %s blacklisted, ignoring." % obj['CKA_LABEL']
elif obj['CKA_TRUST_SERVER_AUTH'] in ('CKT_NETSCAPE_TRUSTED_DELEGATOR',
'CKT_NSS_TRUSTED_DELEGATOR'):
trust[obj['CKA_LABEL']] = True
@@ -104,13 +104,13 @@ for obj in objects:
trust[obj['CKA_LABEL']] = True
elif obj['CKA_TRUST_SERVER_AUTH'] in ('CKT_NETSCAPE_UNTRUSTED',
'CKT_NSS_NOT_TRUSTED'):
- print('!'*74)
- print("UNTRUSTED BUT NOT BLACKLISTED CERTIFICATE FOUND: %s" % obj['CKA_LABEL'])
- print('!'*74)
+ print '!'*74
+ print "UNTRUSTED BUT NOT BLACKLISTED CERTIFICATE FOUND: %s" % obj['CKA_LABEL']
+ print '!'*74
else:
- print("Ignoring certificate %s. SAUTH=%s, EPROT=%s" % \
+ print "Ignoring certificate %s. SAUTH=%s, EPROT=%s" % \
(obj['CKA_LABEL'], obj['CKA_TRUST_SERVER_AUTH'],
- obj['CKA_TRUST_EMAIL_PROTECTION']))
+ obj['CKA_TRUST_EMAIL_PROTECTION'])
for obj in objects:
if obj['CKA_CLASS'] == 'CKO_CERTIFICATE':
@@ -121,19 +121,13 @@ for obj in objects:
.replace('(', '=')\
.replace(')', '=')\
.replace(',', '_')
-
- # this is the only way to decode the way NSS stores multi-byte UTF-8
- if bytes != str:
- bname = bname.encode('utf-8')
- bname = bname.decode('unicode_escape').encode('latin-1').decode('utf-8')
+ bname = bname.decode('string_escape')
fname = bname + '.crt'
-
if os.path.exists(fname):
- print("Found duplicate certificate name %s, renaming." % bname)
+ print "Found duplicate certificate name %s, renaming." % bname
fname = bname + '_2.crt'
f = open(fname, 'w')
f.write("-----BEGIN CERTIFICATE-----\n")
- encoded = base64.b64encode(obj['CKA_VALUE']).decode('utf-8')
- f.write("\n".join(textwrap.wrap(encoded, 64)))
+ f.write("\n".join(textwrap.wrap(base64.b64encode(obj['CKA_VALUE']), 64)))
f.write("\n-----END CERTIFICATE-----\n")