summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xsbin/update-ca-certificates2
2 files changed, 8 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 562a000..bf7dbf1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+ca-certificates (20140224) UNRELEASED; urgency=medium
+
+ * Add trailing newline to certificate, if it is missing. Closes: #635570
+
+ -- Michael Shuler <michael@pbandjelly.org> Sun, 23 Feb 2014 23:22:29 -0600
+
ca-certificates (20140223) unstable; urgency=medium
* No longer ship cacert.org certificates. Closes: #718434, LP: #1258286
diff --git a/sbin/update-ca-certificates b/sbin/update-ca-certificates
index 28d9a69..aa16771 100755
--- a/sbin/update-ca-certificates
+++ b/sbin/update-ca-certificates
@@ -69,6 +69,8 @@ add() {
ln -sf "$CERT" "$PEM"
echo +$PEM >> "$ADDED"
fi
+ # Add trailing newline to certificate, if it is missing (#635570)
+ sed -i '$a\' "$CERT"
cat "$CERT" >> "$TEMPBUNDLE"
}