summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 93953a7f2..264623d8a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -386,6 +386,29 @@ CAIRO_ENABLE_SURFACE_BACKEND(glesv2, OpenGLESv2, no, [
])
dnl ===========================================================================
+CAIRO_ENABLE_SURFACE_BACKEND(glesv3, OpenGLESv3, no, [
+ glesv3_REQUIRES="glesv3"
+ PKG_CHECK_MODULES(glesv3, $glesv3_REQUIRES,, [
+ dnl Fallback to searching for headers
+ AC_CHECK_HEADER(GLES3/gl3.h,, [use_glesv3="no (glesv3.pc nor OpenGL ES 3.0 headers not found)"])
+ if test "x$use_glesv3" = "xyes"; then
+ glesv3_NONPKGCONFIG_CFLAGS=
+ dnl glesv3 is provided by the libGLESv2 library (there is no separate libGLESv3)
+ glesv3_NONPKGCONFIG_LIBS="-lGLESv2"
+ fi])
+
+ if test "x$have_dl" = "xyes" -a "x$have_dlsym" = "xyes"; then
+ glesv3_LIBS="$glesv3_LIBS -ldl"
+ fi
+
+ if test "x$use_glesv3" = "xyes" -a "x$use_gl" = "xyes"; then
+ AC_MSG_ERROR([use either --enable-gl=yes or --enable-glesv3=yes. Not both at the same time.])
+ fi
+
+ need_egl_functions=yes
+])
+
+dnl ===========================================================================
CAIRO_ENABLE_SURFACE_BACKEND(cogl, Cogl, no, [
cogl_REQUIRES="cogl-2.0-experimental"
PKG_CHECK_MODULES(cogl, $cogl_REQUIRES,, [use_cogl="no"])