summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 67a751b25..ca9d72825 100644
--- a/meson.build
+++ b/meson.build
@@ -115,7 +115,6 @@ check_funcs = [
'funlockfile',
'getline',
'link',
- 'strndup',
'fork',
'waitpid',
'raise',
@@ -836,6 +835,8 @@ foreach name : check_funcs
endif
endforeach
+conf.set('HAVE_STRNDUP', cc.has_function('strndup', prefix : '#include <string.h>'))
+
pthread_c_args = []
pthread_link_args = []