summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build68
1 files changed, 52 insertions, 16 deletions
diff --git a/test/meson.build b/test/meson.build
index 47d590690..548e25b4d 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -24,10 +24,12 @@ test_sources = [
'bug-spline.c',
'big-trap.c',
'bilevel-image.c',
- 'bug-40410.c',
+ 'bug-277.c',
'bug-361.c',
+ 'bug-40410.c',
'bug-431.c',
'bug-448.c',
+ 'bug-535.c',
'bug-51910.c',
'bug-75705.c',
'bug-84115.c',
@@ -94,6 +96,7 @@ test_sources = [
'create-for-stream.c',
'create-from-broken-png-stream.c',
'create-from-png.c',
+ 'create-from-png-16bit.c',
'create-from-png-stream.c',
'culled-glyphs.c',
'curve-to-as-line-to.c',
@@ -304,6 +307,7 @@ test_sources = [
'rotated-clip.c',
'rounded-rectangle-fill.c',
'rounded-rectangle-stroke.c',
+ 'round-join-bug-520.c',
'sample.c',
'scale-down-source-surface-paint.c',
'scale-offset-image.c',
@@ -425,15 +429,14 @@ test_ft_font_sources = [
'ft-text-antialias-none.c',
]
-test_gl_sources = [
- 'gl-device-release.c',
- 'gl-oversized-surface.c',
- 'gl-surface-source.c',
+test_ft_svg_font_sources = [
+ 'ft-svg-color-font.c',
]
-test_egl_sources = [
- 'egl-oversized-surface.c',
- 'egl-surface-source.c',
+test_ft_svg_ttx_font_sources = [
+ 'ft-svg-cairo-logo.c',
+ 'ft-svg-render.c',
+ 'ft-svg-render-color.c'
]
test_quartz_sources = [
@@ -480,6 +483,7 @@ test_multi_page_sources = [
]
test_fallback_resolution_sources = [
+ 'create-regions.c',
'fallback-resolution.c',
]
@@ -515,6 +519,18 @@ ps2png_sources = [
'ps2png.c',
]
+test_ttx_fonts = [
+ 'cairo-logo-font.ttx',
+ 'cairo-svg-test-color.ttx',
+ 'cairo-svg-test-doc.ttx',
+ 'cairo-svg-test-fill.ttx',
+ 'cairo-svg-test-gradient.ttx',
+ 'cairo-svg-test-path.ttx',
+ 'cairo-svg-test-shapes.ttx',
+ 'cairo-svg-test-stroke.ttx',
+ 'cairo-svg-test-transform.ttx',
+]
+
build_any2ppm = false
has_multipage_surfaces = false
add_fallback_resolution = false
@@ -525,6 +541,12 @@ endif
if feature_conf.get('CAIRO_HAS_FT_FONT', 0) == 1 and feature_conf.get('CAIRO_HAS_FC_FONT', 0) == 1
test_sources += test_ft_font_sources
+ if conf.get('HAVE_FT_SVG_DOCUMENT', 0) == 1
+ test_sources += test_ft_svg_font_sources
+ if conf.get('CAIRO_CAN_TEST_TTX_FONT', 0) == 1
+ test_sources += test_ft_svg_ttx_font_sources
+ endif
+ endif
endif
if feature_conf.get('CAIRO_HAS_QUARTZ_SURFACE', 0) == 1
@@ -563,10 +585,6 @@ if feature_conf.get('CAIRO_HAS_XLIB_XRENDER_SURFACE', 0) == 1
test_sources += test_xlib_xrender_sources
endif
-if feature_conf.get('CAIRO_HAS_EGL_FUNCTIONS', 0) == 1
- test_sources += test_egl_sources
-endif
-
if has_multipage_surfaces
test_sources += test_multi_page_sources
endif
@@ -629,18 +647,30 @@ exe = executable('cairo-test-suite', [cairo_test_suite_sources, test_sources, ca
libpdiff_dep],
)
-html_files = ['index.html', 'testtable.js', 'view-test-results.py']
-foreach file : html_files
+build_dir_files = ['completion.bash', 'index.html', 'testtable.js', 'view-test-results.py']
+foreach file : build_dir_files
configure_file(input: file, output : file, copy: true)
endforeach
if build_machine.system() != 'windows'
- run_command('ln', '-sf',
+ run_command('ln', '-sfn',
meson.current_source_dir(),
- join_paths(meson.current_build_dir(), 'srcdir'),
+ meson.current_build_dir() / 'srcdir',
check: true)
endif
+if ttx.found()
+ # By default, if the output file exists, ttx creates a new name. We specify the full
+ # output name to make ttx overwrite the existing file instead of creating a new file.
+ foreach ttx_font : test_ttx_fonts
+ custom_target(ttx_font,
+ input: ttx_font,
+ command: [ ttx, '-q', '-o', '@OUTDIR@' / '@BASENAME@.ttf', '@INPUT@' ],
+ output: '@BASENAME@.ttf',
+ build_by_default: true)
+ endforeach
+endif
+
env = environment()
env.set('srcdir', meson.current_source_dir())
@@ -651,3 +681,9 @@ test('cairo', exe,
suite: ['cairo-test-suite', 'slow'],
workdir: meson.current_build_dir(),
depends: test_depends)
+
+# The SVG renderer debug tools can only be built if the _cairo_debug_svg_render()
+# function has been exposed by defining DEBUG_SVG_RENDER
+if conf.get('HAVE_FT_SVG_DOCUMENT', 0) == 1 and cc.get_define('DEBUG_SVG_RENDER') != ''
+ subdir('svg')
+endif