summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Lanin <alex@lanin.de>2020-10-26 22:06:10 +0100
committerGitHub <noreply@github.com>2020-10-26 22:06:10 +0100
commit6f40db00c55cb5dab078d85cb2c5f13af13bbef1 (patch)
treeefaf450bfcf19be47d0d1e7de0d8298efd552e78 /CMakeLists.txt
parenta90e0465ebec2c7abfbc43a0acc0dd23fa140065 (diff)
downloadccache-6f40db00c55cb5dab078d85cb2c5f13af13bbef1.tar.gz
CI: List all configurations explicitly (#690)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4807df3c..3d9e9915 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -43,6 +43,9 @@ if((CMAKE_CXX_COMPILER_ID STREQUAL "Clang" AND CMAKE_CXX_COMPILER_VERSION VERSIO
"The compiler you are using is rather old.\n"
"If anything goes wrong you might be better off with one listed here:"
" https://ccache.dev/platform-compiler-language-support.html")
+
+ # Warnings of those old compilers are probably useless anyway.
+ option(WARNINGS_AS_ERRORS "Treat compiler warnings as errors" FALSE)
endif()
#