summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoel Rosdahl <joel@rosdahl.net>2020-10-23 15:40:07 +0200
committerJoel Rosdahl <joel@rosdahl.net>2020-10-23 15:40:59 +0200
commita90e0465ebec2c7abfbc43a0acc0dd23fa140065 (patch)
tree640cd59ec8655c35e0d0084bebe1c0c0ce609d83 /CMakeLists.txt
parent1e7f56fad15e6e6b34f3fa5035f816984a180e21 (diff)
downloadccache-a90e0465ebec2c7abfbc43a0acc0dd23fa140065.tar.gz
Tweak formulations and fix spelling in CMakeLists.txt
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt32
1 files changed, 18 insertions, 14 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 14ff9690..4807df3c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,28 +19,32 @@ set(CMAKE_EXPORT_COMPILE_COMMANDS TRUE)
list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
#
-#
-# Minimum compiler requirements
-# (Fail gracefully instead of cryptic C++ error messages)
-#
+# Minimum compiler requirements (fail gracefully instead of producing cryptic
+# C++ error messages)
#
-# Clang 3.4 and AppleClang 6.0 do not compile doctest.
-# Gcc 4.8.5 has been the minimum version for quite a while.
+# Clang 3.4 and AppleClang 6.0 fail to compile doctest.
+# GCC 4.8.4 is known to work OK but give warnings.
if((CMAKE_CXX_COMPILER_ID STREQUAL "Clang" AND CMAKE_CXX_COMPILER_VERSION VERSION_LESS 3.5)
-OR (CMAKE_CXX_COMPILER_ID STREQUAL "GNU" AND CMAKE_CXX_COMPILER_VERSION VERSION_LESS 4.8.5)
-OR (CMAKE_CXX_COMPILER_ID STREQUAL "AppleClang" AND CMAKE_CXX_COMPILER_VERSION VERSION_LESS 7.0))
- message(FATAL_ERROR "The compiler you are using is too old, sorry.\nYou need one listed here: https://ccache.dev/platform-compiler-language-support.html")
+ OR (CMAKE_CXX_COMPILER_ID STREQUAL "GNU" AND CMAKE_CXX_COMPILER_VERSION VERSION_LESS 4.8.4)
+ OR (CMAKE_CXX_COMPILER_ID STREQUAL "AppleClang" AND CMAKE_CXX_COMPILER_VERSION VERSION_LESS 7.0))
+ message(
+ FATAL_ERROR
+ "The compiler you are using is too old, sorry.\n"
+ "You need one listed here: https://ccache.dev/platform-compiler-language-support.html")
endif()
-# All Clang problems / special handling ccache has is because of 3.5.
-# All gcc problems / special handling ccache has is because of 4.8.5.
+# All Clang problems / special handling ccache has are because of version 3.5.
+# All GCC problems / special handling ccache has are because of version 4.8.4.
if((CMAKE_CXX_COMPILER_ID STREQUAL "Clang" AND CMAKE_CXX_COMPILER_VERSION VERSION_LESS 3.6)
-OR (CMAKE_CXX_COMPILER_ID STREQUAL "GNU" AND CMAKE_CXX_COMPILER_VERSION VERSION_LESS 5.0))
- message(WARNING "The compiler you are using is rather old.\nIf anything goes wrong you might be better of with one listed here: https://ccache.dev/platform-compiler-language-support.html")
+ OR (CMAKE_CXX_COMPILER_ID STREQUAL "GNU" AND CMAKE_CXX_COMPILER_VERSION VERSION_LESS 5.0))
+ message(
+ WARNING
+ "The compiler you are using is rather old.\n"
+ "If anything goes wrong you might be better off with one listed here:"
+ " https://ccache.dev/platform-compiler-language-support.html")
endif()
-
#
# Settings
#