summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoel Rosdahl <joel@rosdahl.net>2015-08-17 19:05:14 +0200
committerJoel Rosdahl <joel@rosdahl.net>2015-08-17 19:43:41 +0200
commitf74c76107933046309861680b741adc67ac2a34e (patch)
tree17ac4c21e86af0b15be761cc9540ab0a56995e36 /configure.ac
parent4cad46e8ee0053144bb00919f0dadd20c1f87013 (diff)
downloadccache-f74c76107933046309861680b741adc67ac2a34e.tar.gz
Fix regression in recent change related to zlib in nonstandard location
To allow for specifying a -L flag in LDFLAGS and have it take effect for -lz, 0220de9c8ebfb18caae2ac1aa163d060e98ceade put -lz in extra_libs instead of extra_ldflags. However, extra_libs is supposed to contain paths to libraries which are prerequisites of the ccache link rule, and some older versions of make got confused by seeing -lz as a prerequisite. This fix is to revert 0220de9c8ebfb18caae2ac1aa163d060e98ceade and instead make sure that LDFLAGS comes before extra_ldflags.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8d8ce92e..9e655889 100644
--- a/configure.ac
+++ b/configure.ac
@@ -120,7 +120,7 @@ if test x${use_bundled_zlib} = xyes; then
extra_libs="zlib/libz.a"
mkdir -p zlib
else
- extra_libs="-lz"
+ extra_ldflags="-lz"
fi
dnl Linking on Windows needs ws2_32