summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTommi Virtanen <tv@hq.newdream.net>2011-01-13 12:59:11 -0800
committerTommi Virtanen <tv@hq.newdream.net>2011-01-14 16:27:16 -0800
commit5045695cd8118c2b56a762fb8dbeb542bd05b5ac (patch)
tree6b51db6319ea21cafb917823b505f2e81121f94b /Makefile.am
parentb0fc2ca0a4f2595a70ffd0415d3ebc0a0672f5e0 (diff)
downloadceph-5045695cd8118c2b56a762fb8dbeb542bd05b5ac.tar.gz
Teach run-cli-tests about build dirs.
An optional argument points can tell it where to put generated files (in this case, virtualenv). Provide the argument in Makefile.am. Options are still passed to cram, so you can say "./src/test/run-cli-tests -i".
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index aa91d448de0..84f2fa85060 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,7 +13,7 @@ check-local:
@cd src/gtest && $(MAKE) $(AM_MAKEFLAGS) lib/libgtest.la lib/libgtest_main.la
# exercise cli tools
- $(srcdir)/src/test/run-cli-tests
+ $(srcdir)/src/test/run-cli-tests '$(top_builddir)/src/test'
# "make distclean" both runs this and recurses into src/gtest, if
# gtest is in DIST_SUBDIRS. Take extra care to not fail when