summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSage Weil <sage@inktank.com>2012-06-13 11:05:43 -0700
committerSage Weil <sage@inktank.com>2012-06-13 11:05:53 -0700
commit66553d25f09f0d0cea735a862a228060b72c0ce6 (patch)
treeb988a877ba5582bd726f4c67df83898ad6a867f1 /Makefile.am
parentc4a607aa1fa8c07455d947a297c72521b4c7df7d (diff)
downloadceph-66553d25f09f0d0cea735a862a228060b72c0ce6.tar.gz
Makefile: link gtest statically
The problem: - the unittests link against gtest, and gtest is not installed. that's normally fine, but... - rbd and rados api unit tests link against gtest, and are installed by 'make install'. they are needed for teuthology runs, etc. - if we build gtest as an .la library, we can only control whether *all* or *no* .la libraries are linked statically. - we want librados to be linked dynamically. The solution: - build gtest as .a instead of a libtool library - link it statically, always. Unit test binaries are bigger now. Oh well... Fixes: #2331 Signed-off-by: Sage Weil <sage@inktank.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 3a73edfa6c2..b938f916d54 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,13 +15,13 @@ all-local:
if WITH_DEBUG
# We need gtest to build the rados-api tests. We only build those in
# a debug build, though.
- @cd src/gtest && $(MAKE) $(AM_MAKEFLAGS) lib/libgtest.la lib/libgtest_main.la lib/libgtest.a lib/libgtest_main.a
+ @cd src/gtest && $(MAKE) $(AM_MAKEFLAGS) lib/libgtest.a lib/libgtest_main.a
endif
check-local:
# We build gtest this way, instead of using SUBDIRS, because with that,
# gtest's own tests would be run and that would slow us down.
- @cd src/gtest && $(MAKE) $(AM_MAKEFLAGS) lib/libgtest.la lib/libgtest_main.la
+ @cd src/gtest && $(MAKE) $(AM_MAKEFLAGS) lib/libgtest.a lib/libgtest_main.a
# exercise cli tools
$(srcdir)/src/test/run-cli-tests '$(top_builddir)/src/test'