summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSage Weil <sage.weil@dreamhost.com>2011-08-21 16:38:01 -0700
committerSage Weil <sage.weil@dreamhost.com>2011-08-21 17:53:19 -0700
commit6decfa742f7f567c74790c8bd6228d03efde4362 (patch)
tree62fec6da62373017ee0ffe9e38ced60fbde894e7 /Makefile.am
parentb02a347136f79532b4e9a42e817df2e43c8817ec (diff)
downloadceph-6decfa742f7f567c74790c8bd6228d03efde4362.tar.gz
Makefile: allow gtest to be linked in statically
Use UNITTEST_STATIC_LDADD instead of UNITTEST_LDADD. Signed-off-by: Sage Weil <sage.weil@dreamhost.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4e3386b1ecb..91304f28ecb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,7 +14,7 @@ all-local:
if WITH_DEBUG
# We need gtest to build the rados-api tests. We only build those in
# a debug build, though.
- @cd src/gtest && $(MAKE) $(AM_MAKEFLAGS) lib/libgtest.la lib/libgtest_main.la
+ @cd src/gtest && $(MAKE) $(AM_MAKEFLAGS) lib/libgtest.la lib/libgtest_main.la lib/libgtest.a lib/libgtest_main.a
endif
check-local: