summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorColin Patrick McCabe <cmccabe@alumni.cmu.edu>2011-08-09 15:21:53 -0700
committerColin Patrick McCabe <cmccabe@alumni.cmu.edu>2011-08-09 16:02:52 -0700
commite442a2c3773dc33dbbc345f4295b909ea3ba8de5 (patch)
tree91f7a13d0b674192a8bc78335bd57b098b83d384 /Makefile.am
parent66050ad7b4fd7a21f98ce04c2cb501c96fe36e2a (diff)
downloadceph-e442a2c3773dc33dbbc345f4295b909ea3ba8de5.tar.gz
Makefile.am: build gtest in debug builds
Formerly, we only built gtest when doing 'make check'. However, the librados-api tests, which are built in debug mode for the 'all' target, also use gtest. So build it when needed. Signed-off-by: Colin McCabe <colin.mccabe@dreamhost.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 10 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 7e79c1f8bcc..4e3386b1ecb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,13 +9,18 @@ EXTRA_DIST += \
src/test/downloads \
udev/50-rbd.rules
-check-local:
-# Build gtest before we build our own tests. Doing this instead
-# of SUBDIRS because with that, gtest's own tests would be run
-# and that would slow us down.
- @echo "Making lib/libgtest.a lib/libgtest_main.a in src/gtest"
+
+all-local:
+if WITH_DEBUG
+# We need gtest to build the rados-api tests. We only build those in
+# a debug build, though.
@cd src/gtest && $(MAKE) $(AM_MAKEFLAGS) lib/libgtest.la lib/libgtest_main.la
+endif
+check-local:
+# We build gtest this way, instead of using SUBDIRS, because with that,
+# gtest's own tests would be run and that would slow us down.
+ @cd src/gtest && $(MAKE) $(AM_MAKEFLAGS) lib/libgtest.la lib/libgtest_main.la
# exercise cli tools
$(srcdir)/src/test/run-cli-tests '$(top_builddir)/src/test'