summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTommi Virtanen <tv@hq.newdream.net>2011-01-11 16:43:46 -0800
committerTommi Virtanen <tv@hq.newdream.net>2011-01-11 16:43:46 -0800
commitf4a0c2f879ff351ce87f45d1e761b7a5964acac9 (patch)
tree80181ee6811c808f85f83d6dc68c8e39259478c2 /Makefile.am
parent9a5a7fe4f0d518d180d16c83c3223fcd476c253a (diff)
downloadceph-f4a0c2f879ff351ce87f45d1e761b7a5964acac9.tar.gz
Add CLI tests for osdmaptool and friends.
Uses a python package "cram" as test runner. Requires PIP (python-pip.deb) installed on the build machine, to actually run these tests. The cram application itself is included as a tarball that gets installed in a virtualenv when the tests are run. cram is GPL.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 8879c60f4cc..629ad9cb936 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,12 +4,17 @@ EXTRA_DIST = autogen.sh ceph.spec.in
SUBDIRS = . src man
-# Build gtest before we build our own tests. Doing this instead of
-# SUBDIRS gtest's own tests being run and slowing us down.
check-local:
+# Build gtest before we build our own tests. Doing this
+# instead of SUBDIRS gtest's own tests being run and slowing
+# us down.
@echo "Making lib/libgtest.a lib/libgtest_main.a in src/gtest"
@cd src/gtest && $(MAKE) $(AM_MAKEFLAGS) lib/libgtest.la lib/libgtest_main.la
+# exercise cli tools
+ ./src/test/run-cli-tests
+
+
# "make distclean" both runs this and recurses into src/gtest, if
# gtest is in DIST_SUBDIRS. Take extra care to not fail when
# effectively cleaned twice.