summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSage Weil <sage@newdream.net>2011-11-11 16:38:35 -0800
committerSage Weil <sage.weil@dreamhost.com>2011-11-11 20:48:59 -0800
commit2253c0168dda83c508a68c2fedd97e967bf792a3 (patch)
tree2dea6a7ca240e2816f5023a1c6685ace74564a27 /configure.ac
parentcf0a53e1ed81f6fff696bb6683291c313cb09027 (diff)
downloadceph-2253c0168dda83c508a68c2fedd97e967bf792a3.tar.gz
use libuuid for fsid
Signed-off-by: Sage Weil <sage@newdream.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ec0da8a64d7..bd6ed431b07 100644
--- a/configure.ac
+++ b/configure.ac
@@ -68,6 +68,7 @@ AC_CHECK_CC_FLAG([-Wtype-limits], [WARN_TYPE_LIMITS])
AC_CHECK_CC_FLAG([-Wignored-qualifiers], [WARN_IGNORED_QUALIFIERS])
# Checks for libraries.
+AC_CHECK_LIB([uuid], [uuid_parse], [true], AC_MSG_FAILURE([libuuid not found]))
AC_CHECK_LIB([m], [pow], [true], AC_MSG_FAILURE([libm not found]))
AC_CHECK_LIB([pthread], [pthread_create], [true], AC_MSG_FAILURE([libpthread not found]))
if test x"$linux" = x"yes"; then