summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFlorian Haas <florian@hastexo.com>2011-12-29 20:58:01 +0100
committerSage Weil <sage@newdream.net>2011-12-30 09:00:30 -0800
commit92cfad42030889d52911814faa717bebbd4dd22f (patch)
treec0e8ecda09c6d6fbb8c149835a46ea5ece24ed83 /configure.ac
parent66170633ff4c90dc7b71ab2fd056b367980e3cfc (diff)
downloadceph-92cfad42030889d52911814faa717bebbd4dd22f.tar.gz
Add OCF-compliant resource agent for Ceph daemons
Add a wrapper around the ceph init script that makes MDS, OSD and MON configurable as Open Cluster Framework (OCF) compliant cluster resources. Allows Ceph daemons to tie in with cluster resource managers that support OCF, such as Pacemaker (http://www.clusterlabs.org). Disabled by default, configure --with-ocf to enable. Signed-off-by: Florian Haas <florian@hastexo.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 60f998c7f41..e334a245d5d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -277,6 +277,12 @@ AM_CONDITIONAL(WITH_LIBATOMIC, [test "$HAVE_ATOMIC_OPS" = "1"])
# [],
# [with_newsyn=no])
+AC_ARG_WITH([ocf],
+ [AS_HELP_STRING([--with-ocf], [build OCF-compliant cluster resource agent])],
+ ,
+ [with_ocf=no])
+AM_CONDITIONAL(WITH_OCF, [ test "$with_ocf" = "yes" ])
+
# Checks for header files.
AC_HEADER_DIRENT
AC_HEADER_STDC
@@ -375,6 +381,8 @@ AM_PATH_PYTHON([2.4],
AC_CONFIG_HEADERS([src/acconfig.h])
AC_CONFIG_FILES([Makefile
src/Makefile
+ src/ocf/Makefile
+ src/ocf/ceph
man/Makefile
ceph.spec])
AC_OUTPUT