summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKacper Kowalik (Xarthisius) <xarthisius@gentoo.org>2012-01-07 15:32:17 +0100
committerSage Weil <sage.weil@dreamhost.com>2012-01-12 09:17:24 -0800
commitc5144eed4eadf5cfaa0a41c0ced2a1cd3462289f (patch)
tree0e4b6be1d4edf3a68ed8e5bc34aca62f3344d711 /configure.ac
parent7bf01b11614d7b5f4cd7804376debbb2511b7252 (diff)
downloadceph-c5144eed4eadf5cfaa0a41c0ced2a1cd3462289f.tar.gz
Makefile: Use ACX_PTHREAD in configure.ac and resulting flags in src/Makefile.am
instead of hardcoded flags Signed-off-by: Kacper Kowalik (Xarthisius) <xarthisius@gentoo.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e334a245d5d..9ca434c259f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,6 @@
# -*- Autoconf -*-
# Process this file with autoconf to produce a configure script.
+m4_include(m4/acx_pthread.m4)
# Autoconf
AC_PREREQ(2.59)
@@ -68,9 +69,9 @@ AC_CHECK_CC_FLAG([-Wtype-limits], [WARN_TYPE_LIMITS])
AC_CHECK_CC_FLAG([-Wignored-qualifiers], [WARN_IGNORED_QUALIFIERS])
# Checks for libraries.
+ACX_PTHREAD
AC_CHECK_LIB([uuid], [uuid_parse], [true], AC_MSG_FAILURE([libuuid not found]))
AC_CHECK_LIB([m], [pow], [true], AC_MSG_FAILURE([libm not found]))
-AC_CHECK_LIB([pthread], [pthread_create], [true], AC_MSG_FAILURE([libpthread not found]))
if test x"$linux" = x"yes"; then
AC_CHECK_LIB([keyutils], [add_key], [true], AC_MSG_FAILURE([libkeyutils not found]))
fi