summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJosh Durgin <josh.durgin@dreamhost.com>2011-06-07 13:57:28 -0700
committerJosh Durgin <josh.durgin@dreamhost.com>2011-06-07 13:57:28 -0700
commitdfa4aeb8aed450a706d4c7fc0ad929a54faa2085 (patch)
treecaf0c3a63837feca42be8cf5033b6fcde70edc5c /configure.ac
parent12bb3081359b889c380d2df333ac370cc2ec865e (diff)
parentb32f00ebe32fd57264a1527641cfb7cd0844e81f (diff)
downloadceph-dfa4aeb8aed450a706d4c7fc0ad929a54faa2085.tar.gz
Merge remote branch 'origin/wip_gcov'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0b24fdd5b94..d1b22934d88 100644
--- a/configure.ac
+++ b/configure.ac
@@ -141,6 +141,14 @@ AM_CONDITIONAL(WITH_DEBUG, test "$with_debug" = "yes")
AC_DEFINE([DEBUG_GATHER], [1], [Define if you want C_Gather debugging])
+# code coverage?
+AC_ARG_ENABLE([coverage],
+ [AS_HELP_STRING([--enable-coverage], [enable code coverage tracking])],
+ [],
+ [enable_coverage=no])
+AM_CONDITIONAL(ENABLE_COVERAGE, test "x$enable_coverage" != xno)
+AC_SUBST(GCOV_PREFIX_STRIP, `echo $(pwd)/src | tr -dc / | wc -c`)
+
# radosgw?
AC_ARG_WITH([radosgw],
[AS_HELP_STRING([--with-radosgw], [build RADOS gateway])],