summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSam Lang <sam.lang@inktank.com>2012-10-16 11:45:26 -0500
committerSage Weil <sage@inktank.com>2012-10-16 18:26:29 -0700
commit328bf482349485b90911fe8953d8ce5f0769c69e (patch)
treeeb86366bec552fc972bd82cec00c9a837a1ba497 /configure.ac
parent58020d44c754fc3cdde19cbca248ac398ef6becf (diff)
downloadceph-328bf482349485b90911fe8953d8ce5f0769c69e.tar.gz
client: Add permissions checking to open
Users of the libcephfs api (fuse in particular) don't check the mode against the open flags. This commit does the proper checks to grant/deny access to the file. The check_mode() function constructs a requested mode based on the flags, and compares that to the mode of the file. Signed-off-by: Sam Lang <sam.lang@inktank.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4d03635b761..94c93d744e0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -308,6 +308,9 @@ AS_IF([test "x$with_system_leveldb" = xcheck],
[AC_CHECK_LIB([leveldb], [leveldb_open], [with_system_leveldb=yes], [], [-lsnappy -lpthread])])
AM_CONDITIONAL(WITH_SYSTEM_LEVELDB, [ test "$with_system_leveldb" = "yes" ])
+# look for fuse_getgroups and define FUSE_GETGROUPS if found
+AC_CHECK_FUNCS([fuse_getgroups])
+
# use system libs3?
AC_ARG_WITH([system-libs3],
[AS_HELP_STRING([--with-system-libs3], [use system libs3])],