summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGary Lowell <glowell@inktank.com>2012-10-08 10:04:25 -0700
committerGary Lowell <glowell@inktank.com>2012-10-15 14:14:34 -0700
commit3658157b6015cb4864570a438204b1d552d1fc00 (patch)
treec4b637663865f493180527644d1dc4e2da6fa9d2 /configure.ac
parentaed3612f875a3aeb6463011cb630adc7c936adbd (diff)
downloadceph-3658157b6015cb4864570a438204b1d552d1fc00.tar.gz
Makefile: Updates to eliminates warnings, add test for boost system lib.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d5e9ebfc7fe..97797228162 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,6 +9,7 @@ AC_PREREQ(2.59)
# VERSION define is not used by the code. It gets a version string
# from 'git describe'; see src/ceph_ver.[ch]
AC_INIT([ceph], [0.52], [ceph-devel@vger.kernel.org])
+AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_SUBDIRS([src/gtest])
AC_CONFIG_SUBDIRS([src/leveldb])
@@ -360,6 +361,9 @@ AC_CHECK_HEADER([boost/random/discrete_distribution.hpp],
AC_CHECK_HEADER([boost/statechart/state.hpp], [],
AC_MSG_FAILURE(["Can't find boost statechart headers; need 1.34 or later"]))
+AC_CHECK_LIB(boost_system-mt, main, [],
+ AC_MSG_ERROR(["Boost system library not found."]))
+
AC_LANG([C])
AC_CHECK_MEMBER([struct fiemap_extent.fe_logical],