summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGreg Farnum <greg@inktank.com>2013-04-17 13:21:04 -0700
committerSage Weil <sage@inktank.com>2013-04-17 15:14:35 -0700
commit8f21beb23cf0ca1834f5cc42737530b3cbcb72ec (patch)
tree0bd9bbe06e0bcdd260c44e9a043c000e63d43941 /configure.ac
parent4bf244821027ead759687c5d3bdfe708caa6d89a (diff)
downloadceph-8f21beb23cf0ca1834f5cc42737530b3cbcb72ec.tar.gz
leveldbstore: handle old versions of leveldb
The filter_policy (bloom filter) stuff is fairly new in LevelDB's life, and it turns out that precise's version is too old for it. Add conditional compilation for those members in order to build and work properly. Signed-off-by: Greg Farnum <greg@inktank.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7be84b40b6f..23e21133e6a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -416,6 +416,10 @@ AM_CONDITIONAL(WITH_OCF, [ test "$with_ocf" = "yes" ])
AC_CHECK_LIB([snappy], [snappy_compress], [], [AC_MSG_FAILURE([libsnappy not found])])
# use system leveldb
AC_CHECK_LIB([leveldb], [leveldb_open], [], [AC_MSG_FAILURE([libleveldb not found])], [-lsnappy -lpthread])
+# see if we can use bloom filters with leveldb
+AC_LANG_PUSH([C++])
+AC_CHECK_HEADER([leveldb/filter_policy.h], [AC_DEFINE([HAVE_LEVELDB_FILTER_POLICY], [1], [Defined if LevelDB supports bloom filters ])])
+AC_LANG_POP([C++])
# use system libs3?
AC_ARG_WITH([system-libs3],