summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorYehuda Sadeh <yehuda@hq.newdream.net>2012-05-01 10:06:19 -0700
committerYehuda Sadeh <yehuda@inktank.com>2012-05-04 15:55:34 -0700
commit150adcceb640930bb6790dc19fc464ef1176a07e (patch)
tree0f31b47e98514da54313286b42ea4286a15ba7e4 /debian
parent53f642e29a6dfd25dc6de39922786af085f6f7e0 (diff)
downloadceph-150adcceb640930bb6790dc19fc464ef1176a07e.tar.gz
debian: add rules for rest-bench
Signed-off-by: Yehuda Sadeh <yehuda@hq.newdream.net>
Diffstat (limited to 'debian')
-rw-r--r--debian/control14
-rw-r--r--debian/rest-bench.install1
-rwxr-xr-xdebian/rules3
3 files changed, 17 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index fc75611a9d8..4a15dfc3eb5 100644
--- a/debian/control
+++ b/debian/control
@@ -304,6 +304,20 @@ Description: debugging symbols for radosgw
.
This package contains debugging symbols for radosgw.
+Package: rest-bench
+Architecture: linux-any
+Depends: ${shlibs:Depends}, ${misc:Depends}, ceph-common, xml2, curl
+Description: RESTful bencher that can be used to benchmark
+ radosgw performance.
+
+Package: rest-bench-dbg
+Architecture: linux-any
+Section: debug
+Priority: extra
+Depends: ${shlibs:Depends}, ${misc:Depends}, ceph-common, xml2, curl
+Description: RESTful bencher that can be used to benchmark
+ radosgw performance.
+
Package: obsync
Architecture: linux-any
Depends: ${misc:Depends}, python, python-boto, python-ceph, python-pyxattr, python-lxml
diff --git a/debian/rest-bench.install b/debian/rest-bench.install
new file mode 100644
index 00000000000..8535f20d5a4
--- /dev/null
+++ b/debian/rest-bench.install
@@ -0,0 +1 @@
+usr/bin/rest-bench
diff --git a/debian/rules b/debian/rules
index 0b0e70bdbfa..e80d95e5a63 100755
--- a/debian/rules
+++ b/debian/rules
@@ -20,7 +20,7 @@ endif
export DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
-extraopts += --with-ocf
+extraopts += --with-ocf --with-rest-bench
ifeq ($(DEB_HOST_ARCH), armel)
# armel supports ARMv4t or above instructions sets.
@@ -117,6 +117,7 @@ binary-arch: build install
dh_strip -pradosgw --dbg-package=radosgw-dbg
dh_strip -pgceph --dbg-package=gceph-dbg
dh_strip -plibrgw1 --dbg-package=librgw1-dbg
+ dh_strip -prest-bench --dbg-package=rest-bench-dbg
dh_compress
dh_fixperms