summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSage Weil <sage@newdream.net>2012-05-07 15:57:31 -0700
committerSage Weil <sage@newdream.net>2012-05-07 15:57:31 -0700
commitac903210d0cd80e6a1205d178483a16a6ae4f014 (patch)
treeacec2ad224cdc95ba969083e992f6df671f6b94e /debian
parentefc0701cf97f6a936c8f253b5449216f309fe4a3 (diff)
parent6c2c883c175421d8c492c64154ed3e26bbdd6595 (diff)
downloadceph-ac903210d0cd80e6a1205d178483a16a6ae4f014.tar.gz
Merge branch 'wip-rgw-bench'
Conflicts: debian/rules
Diffstat (limited to 'debian')
-rw-r--r--debian/control16
-rw-r--r--debian/rest-bench.install1
-rwxr-xr-xdebian/rules3
3 files changed, 18 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index 0a251b01f06..b482caa8745 100644
--- a/debian/control
+++ b/debian/control
@@ -6,7 +6,7 @@ Vcs-Git: git://github.com/ceph/ceph.git
Vcs-Browser: https://github.com/ceph/ceph
Maintainer: Laszlo Boszormenyi (GCS) <gcs@debian.hu>
Uploaders: Sage Weil <sage@newdream.net>
-Build-Depends: debhelper (>= 6.0.7~), autotools-dev, autoconf, automake, libfuse-dev, libboost-dev (>= 1.34), libedit-dev, libcrypto++-dev, libtool, libexpat1-dev, libfcgi-dev, libatomic-ops-dev, libgoogle-perftools-dev [i386 amd64], pkg-config, libgtkmm-2.4-dev, python, libcurl4-gnutls-dev, libkeyutils-dev, uuid-dev, libaio-dev, python (>= 2.6.6-3~)
+Build-Depends: debhelper (>= 6.0.7~), autotools-dev, autoconf, automake, libfuse-dev, libboost-dev (>= 1.34), libedit-dev, libcrypto++-dev, libtool, libexpat1-dev, libfcgi-dev, libatomic-ops-dev, libgoogle-perftools-dev [i386 amd64], pkg-config, libgtkmm-2.4-dev, python, libcurl4-gnutls-dev, libkeyutils-dev, uuid-dev, libaio-dev, python (>= 2.6.6-3~), libxml2-dev
Standards-Version: 3.9.3
Package: ceph
@@ -271,6 +271,20 @@ Description: debugging symbols for radosgw
.
This package contains debugging symbols for radosgw.
+Package: rest-bench
+Architecture: linux-any
+Depends: ${shlibs:Depends}, ${misc:Depends}, ceph-common, xml2, curl
+Description: RESTful bencher that can be used to benchmark
+ radosgw performance.
+
+Package: rest-bench-dbg
+Architecture: linux-any
+Section: debug
+Priority: extra
+Depends: ${shlibs:Depends}, ${misc:Depends}, ceph-common, xml2, curl
+Description: RESTful bencher that can be used to benchmark
+ radosgw performance.
+
Package: obsync
Architecture: linux-any
Depends: ${misc:Depends}, python, python-boto, python-ceph, python-pyxattr, python-lxml
diff --git a/debian/rest-bench.install b/debian/rest-bench.install
new file mode 100644
index 00000000000..8535f20d5a4
--- /dev/null
+++ b/debian/rest-bench.install
@@ -0,0 +1 @@
+usr/bin/rest-bench
diff --git a/debian/rules b/debian/rules
index 5d02e96ac79..84f3daa2789 100755
--- a/debian/rules
+++ b/debian/rules
@@ -20,7 +20,7 @@ endif
export DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
-extraopts += --with-ocf
+extraopts += --with-ocf --with-rest-bench
ifeq ($(DEB_HOST_ARCH), armel)
# armel supports ARMv4t or above instructions sets.
@@ -116,6 +116,7 @@ binary-arch: build install
dh_strip -plibcephfs1 --dbg-package=libcephfs1-dbg
dh_strip -pradosgw --dbg-package=radosgw-dbg
dh_strip -pgceph --dbg-package=gceph-dbg
+ dh_strip -prest-bench --dbg-package=rest-bench-dbg
dh_compress
dh_fixperms