summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSage Weil <sage@newdream.net>2012-05-06 14:50:30 -0700
committerSage Weil <sage@newdream.net>2012-05-06 14:50:30 -0700
commitcaab859b6d4e7dd59e9f660a0fc710226ad3d3ff (patch)
treeb24322aab74e96b4346516b415ba8544ea0b1e2d /debian
parente2ee1973f9063dd05e299a43ee3a476fb3195962 (diff)
downloadceph-caab859b6d4e7dd59e9f660a0fc710226ad3d3ff.tar.gz
debian: kill librgw.so
Signed-off-by: Sage Weil <sage@newdream.net>
Diffstat (limited to 'debian')
-rw-r--r--debian/.gitignore3
-rw-r--r--debian/control33
-rw-r--r--debian/librgw-dev.install4
-rw-r--r--debian/librgw1.install2
-rw-r--r--debian/librgw1.postinst41
-rw-r--r--debian/librgw1.postrm43
-rwxr-xr-xdebian/rules1
7 files changed, 0 insertions, 127 deletions
diff --git a/debian/.gitignore b/debian/.gitignore
index 1409714d502..b7ad8ec5297 100644
--- a/debian/.gitignore
+++ b/debian/.gitignore
@@ -21,9 +21,6 @@
/librbd1
/radosgw-dbg
/radosgw
-/librgw-dev
-/librgw1
-/librgw1-dbg
/gceph-dbg
/gceph
/obsync
diff --git a/debian/control b/debian/control
index 4653b4bab99..0a251b01f06 100644
--- a/debian/control
+++ b/debian/control
@@ -247,39 +247,6 @@ Description: Ceph distributed file system client library (development files)
This package contains development files needed for building applications that
link against libcephfs.
-Package: librgw1
-Architecture: linux-any
-Section: libs
-Depends: ${shlibs:Depends}, ${misc:Depends}
-Description: radosgw data access library
- radosgw is a REST gateway for RADOS distributed object store.
- librgw contains support for reading and writing objects in the
- format expected by radosgw.
-
-Package: librgw1-dbg
-Architecture: linux-any
-Section: debug
-Priority: extra
-Depends: librgw1 (= ${binary:Version}), ${misc:Depends}
-Description: debugging symbols for librgw
- radosgw is a REST gateway for RADOS distributed object store.
- librgw contains support for reading and writing objects in the
- format expected by radosgw.
- .
- This package contains debugging symbols for librgw.
-
-Package: librgw-dev
-Architecture: linux-any
-Section: libdevel
-Depends: ${misc:Depends}, librgw1 (= ${binary:Version})
-Description: RGW distributed object store client library (development files)
- radosgw is a REST gateway for RADOS distributed object store.
- librgw contains support for reading and writing objects in the
- format expected by radosgw.
- .
- This package contains development files needed for building applications that
- link against librgw.
-
Package: radosgw
Architecture: linux-any
Depends: ${shlibs:Depends}, ${misc:Depends}, ceph-common
diff --git a/debian/librgw-dev.install b/debian/librgw-dev.install
deleted file mode 100644
index 4a52756aa93..00000000000
--- a/debian/librgw-dev.install
+++ /dev/null
@@ -1,4 +0,0 @@
-usr/lib/librgw.so
-usr/lib/librgw.a
-usr/lib/librgw.la
-usr/include/rados/librgw.h
diff --git a/debian/librgw1.install b/debian/librgw1.install
deleted file mode 100644
index 0623f371795..00000000000
--- a/debian/librgw1.install
+++ /dev/null
@@ -1,2 +0,0 @@
-usr/lib/librgw.so.*
-
diff --git a/debian/librgw1.postinst b/debian/librgw1.postinst
deleted file mode 100644
index df6b9fcb3db..00000000000
--- a/debian/librgw1.postinst
+++ /dev/null
@@ -1,41 +0,0 @@
-#!/bin/sh
-#
-# see: dh_installdeb(1)
-
-set -e
-
-# summary of how this script can be called:
-# * <postinst> `configure' <most-recently-configured-version>
-# * <old-postinst> `abort-upgrade' <new version>
-# * <conflictor's-postinst> `abort-remove' `in-favour' <package>
-# <new-version>
-# * <postinst> `abort-remove'
-# * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
-# <failed-install-package> <version> `removing'
-# <conflicting-package> <version>
-# for details, see http://www.debian.org/doc/debian-policy/ or
-# the debian-policy package
-
-
-case "$1" in
- configure)
- ldconfig
- ;;
-
- abort-upgrade|abort-remove|abort-deconfigure)
- ;;
-
- *)
- echo "postinst called with unknown argument \`$1'" >&2
- exit 1
- ;;
-esac
-
-# dh_installdeb will replace this with shell code automatically
-# generated by other debhelper scripts.
-
-#DEBHELPER#
-
-exit 0
-
-
diff --git a/debian/librgw1.postrm b/debian/librgw1.postrm
deleted file mode 100644
index 598f48b6157..00000000000
--- a/debian/librgw1.postrm
+++ /dev/null
@@ -1,43 +0,0 @@
-#!/bin/sh
-# postrm script for ceph
-#
-# see: dh_installdeb(1)
-
-set -e
-
-# summary of how this script can be called:
-# * <postrm> `remove'
-# * <postrm> `purge'
-# * <old-postrm> `upgrade' <new-version>
-# * <new-postrm> `failed-upgrade' <old-version>
-# * <new-postrm> `abort-install'
-# * <new-postrm> `abort-install' <old-version>
-# * <new-postrm> `abort-upgrade' <old-version>
-# * <disappearer's-postrm> `disappear' <overwriter>
-# <overwriter-version>
-# for details, see http://www.debian.org/doc/debian-policy/ or
-# the debian-policy package
-
-
-case "$1" in
- remove)
- ldconfig
- ;;
-
- purge|upgrade|failed-upgrade|abort-install|abort-upgrade|disappear)
- ;;
-
- *)
- echo "postrm called with unknown argument \`$1'" >&2
- exit 1
- ;;
-esac
-
-# dh_installdeb will replace this with shell code automatically
-# generated by other debhelper scripts.
-
-#DEBHELPER#
-
-exit 0
-
-
diff --git a/debian/rules b/debian/rules
index 0b0e70bdbfa..5d02e96ac79 100755
--- a/debian/rules
+++ b/debian/rules
@@ -116,7 +116,6 @@ binary-arch: build install
dh_strip -plibcephfs1 --dbg-package=libcephfs1-dbg
dh_strip -pradosgw --dbg-package=radosgw-dbg
dh_strip -pgceph --dbg-package=gceph-dbg
- dh_strip -plibrgw1 --dbg-package=librgw1-dbg
dh_compress
dh_fixperms