summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTommi Virtanen <tv@inktank.com>2012-08-30 10:16:52 -0400
committerTommi Virtanen <tv@inktank.com>2012-09-05 11:28:04 -0700
commit787a78e8b1d8e5d92ee447b970ec8b79baa46f0b (patch)
tree6b8e34e9dbe89c4c402ae1bf5b0c58b44ac7d794 /src/Makefile.am
parent66aecb1e410a59f3e0ed89a30212b8dc546a3d4a (diff)
downloadceph-787a78e8b1d8e5d92ee447b970ec8b79baa46f0b.tar.gz
upstart, ceph-create-keys: Make client.admin key generation automatic.
This should help simplify Chef etc deployments. Now (when using the Upstart jobs), when a ceph-mon is started, ceph-create-admin-key is triggered. If /etc/ceph/$cluster.client.admin.keyring already exists, it does nothing; otherwise, it waits for ceph-mon to reach quorum, and then does a "ceph auth get-or-create" to create the key, and writes it atomically to disk. The equivalent code can be removed from the Chef cookbook once this is in. Signed-off-by: Tommi Virtanen <tv@inktank.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 91532b4c60b..b57648e2e33 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -28,7 +28,8 @@ bin_DEBUGPROGRAMS =
sbin_PROGRAMS =
sbin_SCRIPTS = \
ceph-disk-prepare \
- ceph-disk-activate
+ ceph-disk-activate \
+ ceph-create-keys
bin_SCRIPTS = ceph-run $(srcdir)/ceph-clsinfo ceph-debugpack ceph-rbdnamer
dist_bin_SCRIPTS =
# C/C++ tests to build will be appended to this
@@ -905,7 +906,8 @@ EXTRA_DIST += \
$(srcdir)/upstart/radosgw-all.conf \
$(srcdir)/upstart/radosgw-all-starter.conf \
ceph-disk-prepare \
- ceph-disk-activate
+ ceph-disk-activate \
+ ceph-create-keys
EXTRA_DIST += $(srcdir)/$(shell_scripts:%=%.in)