summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorEleanor Cawthon <eleanor.cawthon@inktank.com>2012-05-21 17:17:51 -0700
committerEleanor Cawthon <eleanor.cawthon@inktank.com>2012-06-01 13:02:36 -0700
commit7a4e9234d3b257aa66cf3637c64473c53b1bbc2a (patch)
treec2c9fef20c4b53163aba8366e794481dc409d1b4 /src/Makefile.am
parente0f19525f316ef27b96e669bc51fb6e75b6840bc (diff)
downloadceph-7a4e9234d3b257aa66cf3637c64473c53b1bbc2a.tar.gz
test/: Added object map benchmarking tool
omap_bench writes configurable objectmaps to a configurable number of objects and generates latency statistics. Signed-off-by: Eleanor Cawthon <eleanor.cawthon@inktank.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 9ac4f2f406e..ccddb7f88f1 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -214,6 +214,10 @@ testrados_SOURCES = test/osd/TestRados.cc test/osd/TestOpStat.cc test/osd/Object
testrados_LDADD = librados.la $(LIBGLOBAL_LDA)
bin_DEBUGPROGRAMS += testrados
+omapbench_SOURCES = test/omap_bench.cc
+omapbench_LDADD = librados.la $(LIBGLOBAL_LDA)
+bin_DEBUGPROGRAMS += omapbench
+
multi_stress_watch_SOURCES = test/multi_stress_watch.cc test/rados-api/test.cc
multi_stress_watch_LDADD = librados.la $(LIBGLOBAL_LDA)
bin_DEBUGPROGRAMS += multi_stress_watch