summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGary Lowell <glowell@inktank.com>2012-11-06 16:23:18 -0800
committerSage Weil <sage@inktank.com>2013-04-18 13:51:36 -0700
commita975f9dfb18d9fd8db6ffc149caf1e0a49ca8cff (patch)
tree50655900daba1e924a1d3f56c98d7947116ee1f1 /src/Makefile.am
parenta460fa145158666864ea073c97abff937304b39d (diff)
downloadceph-a975f9dfb18d9fd8db6ffc149caf1e0a49ca8cff.tar.gz
packaging: Add ceph-test debian package
The ceph-test package includes optional test and benchmarking programs. Conflicts: debian/control debian/rules
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 10 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 4d774b02a34..f3c38e43f25 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -214,9 +214,9 @@ testrados_SOURCES = test/osd/TestRados.cc test/osd/TestOpStat.cc test/osd/Object
testrados_LDADD = librados.la $(LIBGLOBAL_LDA)
bin_DEBUGPROGRAMS += testrados
-omapbench_SOURCES = test/omap_bench.cc
-omapbench_LDADD = librados.la $(LIBGLOBAL_LDA)
-bin_DEBUGPROGRAMS += omapbench
+#omapbench_SOURCES = test/omap_bench.cc
+#omapbench_LDADD = librados.la $(LIBGLOBAL_LDA)
+#bin_DEBUGPROGRAMS += omapbench
multi_stress_watch_SOURCES = test/multi_stress_watch.cc test/rados-api/test.cc
multi_stress_watch_LDADD = librados.la $(LIBGLOBAL_LDA)
@@ -1619,7 +1619,14 @@ noinst_HEADERS = \
test/osd/TestOpStat.h\
global/pidfile.h\
common/sync_filesystem.h \
+ test/ObjectMap/KeyValueDBMemory.h \
+ test/common/ObjectContents.h \
test/encoding/types.h \
+ test/filestore/workload_generator.h \
+ test/filestore/DeterministicOpSequence.h \
+ test/filestore/FileStoreTracker.h \
+ test/filestore/FileStoreDiff.h \
+ test/filestore/TestFileStoreState.h \
test/system/cross_process_sem.h \
test/system/st_rados_create_pool.h \
test/system/st_rados_list_objects.h \