summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSage Weil <sage.weil@dreamhost.com>2012-04-28 16:25:31 -0700
committerSage Weil <sage.weil@dreamhost.com>2012-04-28 16:25:31 -0700
commitc24c9e3a551ab4af96931b8635f90231c16d7902 (patch)
tree45b30aef068e6891d34f0b02e50030a750e0e907 /src/Makefile.am
parent6bb3e841907a168d9ef4454913382c0dfb429520 (diff)
parent96108c657c5843fc7e3fdfeb35a65f2bead181c3 (diff)
downloadceph-c24c9e3a551ab4af96931b8635f90231c16d7902.tar.gz
Merge remote branch 'gh/wip-filestore-misc'
Conflicts: src/test/filestore/run_seed_to.sh
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b54a544c218..20cb84fdc72 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -744,11 +744,11 @@ test_filestore_CXXFLAGS = ${AM_CXXFLAGS} ${UNITTEST_CXXFLAGS} \
-I$(top_srcdir)/src/leveldb/include
bin_DEBUGPROGRAMS += test_filestore
-test_filestore_workloadgen_SOURCES = test/filestore/workload_generator.cc
+test_filestore_workloadgen_SOURCES = \
+ test/filestore/workload_generator.cc \
+ test/filestore/TestFileStoreState.cc
test_filestore_workloadgen_LDFLAGS = ${AM_LDFLAGS}
-test_filestore_workloadgen_LDADD = ${UNITTEST_STATIC_LDADD} libos.la leveldb/libleveldb.a $(LIBGLOBAL_LDA)
-test_filestore_workloadgen_CXXFLAGS = ${AM_CXXFLAGS} ${UNITTEST_CXXFLAGS} \
- -I$(top_srcdir)/src/leveldb/include
+test_filestore_workloadgen_LDADD = libos.la leveldb/libleveldb.a $(LIBGLOBAL_LDA)
bin_DEBUGPROGRAMS += test_filestore_workloadgen
test_filestore_idempotent_SOURCES = test/filestore/test_idempotent.cc test/filestore/FileStoreTracker.cc test/common/ObjectContents.cc