summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJosh Durgin <josh.durgin@inktank.com>2012-06-07 22:54:45 -0700
committerJosh Durgin <josh.durgin@inktank.com>2012-06-08 16:38:19 -0700
commitdcc7c96339fc6b85b3d1c1e06aa90e4b4d9d4884 (patch)
treede0f5f12cac8eff50e8cad488c331c37dfc171d1 /src/Makefile.am
parent70686c599bc0040bf7e62deae9af007eca8ca120 (diff)
downloadceph-dcc7c96339fc6b85b3d1c1e06aa90e4b4d9d4884.tar.gz
cls_rbd: add methods for interacting with the new header format
Add the client side (cls_rbd_client) for testing as well. librbd will use the functions in cls_rbd_client to interact with cls_rbd. Signed-off-by: Josh Durgin <josh.durgin@inktank.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 74df14d741d..0de11b6bda5 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -701,6 +701,13 @@ test_librbd_fsx_LDADD = librbd.la librados.la
test_librbd_fsx_CFLAGS = ${AM_CFLAGS} -Wno-format
bin_DEBUGPROGRAMS += test_librbd_fsx
+test_cls_rbd_SOURCES = test/rbd/test_cls_rbd.cc \
+ test/rados-api/test.cc \
+ librbd/cls_rbd_client.cc
+test_cls_rbd_LDADD = librados.la ${UNITTEST_STATIC_LDADD}
+test_cls_rbd_CXXFLAGS = ${AM_CXXFLAGS} ${UNITTEST_CXXFLAGS}
+bin_DEBUGPROGRAMS += test_cls_rbd
+
test_rados_api_io_SOURCES = test/rados-api/io.cc test/rados-api/test.cc
test_rados_api_io_LDFLAGS = ${AM_LDFLAGS}
test_rados_api_io_LDADD = librados.la ${UNITTEST_STATIC_LDADD}
@@ -1365,6 +1372,7 @@ noinst_HEADERS = \
librados/IoCtxImpl.h\
librados/PoolAsyncCompletionImpl.h\
librados/RadosClient.h\
+ librbd/cls_rbd_client.h\
librbd/LibrbdWriteback.h\
logrotate.conf\
json_spirit/json_spirit.h\