summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorYan, Zheng <zheng.z.yan@intel.com>2013-08-04 11:51:48 +0800
committerSage Weil <sage@inktank.com>2013-08-15 09:48:22 -0700
commita25d73effb38118602bc73da0aa258c639f69c2c (patch)
tree0a5b2871b6aefd9436c202d73264707439e64ab5 /src/Makefile.am
parent24ec3201ed7a99b6742d35efd4cb728e2f68f69a (diff)
downloadceph-a25d73effb38118602bc73da0aa258c639f69c2c.tar.gz
store: Abstract the underlying filesystem functionality
This patch defines class FileStoreBackend, and use it to abstracts filesystem's functionalities. Fiemap() and syncfs() related code is moved into class GenericFileStoreBackend. All btrfs specific code is moved into class BtrfsFileStoreBackend. Signed-off-by: Yan, Zheng <zheng.z.yan@intel.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e93bbb8f537..3b93c9da325 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1667,7 +1667,9 @@ libos_a_SOURCES = \
os/FlatIndex.cc \
os/DBObjectMap.cc \
os/LevelDBStore.cc \
- os/WBThrottle.cc
+ os/WBThrottle.cc \
+ os/BtrfsFileStoreBackend.cc \
+ os/GenericFileStoreBackend.cc
libos_a_CXXFLAGS= ${AM_CXXFLAGS}
noinst_LIBRARIES += libos.a
@@ -2170,6 +2172,8 @@ noinst_HEADERS = \
os/CollectionIndex.h\
os/FileJournal.h\
os/FileStore.h\
+ os/BtrfsFileStoreBackend.h\
+ os/GenericFileStoreBackend.h\
os/FlatIndex.h\
os/HashIndex.h\
os/FDCache.h\