summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSage Weil <sage@inktank.com>2013-08-16 17:59:11 -0700
committerSage Weil <sage@inktank.com>2013-08-16 17:59:11 -0700
commitd08e05e463f1f7106a1f719d81b849435790a3b9 (patch)
tree6e50bd0355a599d7b05059e978e979219795c941 /src/Makefile.am
parent37bf38f7e8b25414e17114c1f196a92b4e375ac7 (diff)
downloadceph-d08e05e463f1f7106a1f719d81b849435790a3b9.tar.gz
ceph-post-file: single command to upload a file to cephdrop
Use sftp to upload to a directory that only this user and ceph devs can access. Distribute an ssh key to connect to the account. This will let us revoke the key in the future if we feel the need. Also distribute a known_hosts file so that users have some confidence that they are connecting to the real ceph drop account and not some third party. Signed-off-by: Sage Weil <sage@inktank.com> Reviewed-by: Dan Mick <dan.mick@inktank.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index de1b81fb4ba..7c3ade4706f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -39,7 +39,7 @@ ceph_sbin_SCRIPTS = \
sbin_SCRIPTS = \
mount.fuse.ceph
-bin_SCRIPTS = ceph ceph-run ceph-rest-api ceph-clsinfo ceph-debugpack ceph-rbdnamer
+bin_SCRIPTS = ceph ceph-run ceph-rest-api ceph-clsinfo ceph-debugpack ceph-rbdnamer ceph-post-file
dist_bin_SCRIPTS =
# C/C++ tests to build will be appended to this
check_PROGRAMS =
@@ -184,7 +184,7 @@ base: ceph-mon ceph-osd ceph-mds \
ceph-syn \
rados radosgw librados-config \
ceph-conf monmaptool osdmaptool crushtool ceph-authtool \
- init-ceph mkcephfs mon_store_converter
+ init-ceph mkcephfs mon_store_converter ceph-post-file
# fuse targets?
@@ -1287,7 +1287,7 @@ editpaths = sed \
-e 's|@prefix[@]|$(prefix)|g' \
-e 's|@@GCOV_PREFIX_STRIP[@][@]|$(GCOV_PREFIX_STRIP)|g'
-shell_scripts = init-ceph mkcephfs ceph-debugpack ceph-coverage
+shell_scripts = init-ceph mkcephfs ceph-debugpack ceph-coverage ceph-post-file
$(shell_scripts): Makefile