summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2017-04-18 18:13:50 -0500
committerJason R. Coombs <jaraco@jaraco.com>2017-04-18 18:13:50 -0500
commit54b676cc97ed3c5d57f69cd77128c162b9630ac8 (patch)
treea359d66e506c671625700eba3a48a808a642d8bd /setup.py
parentd65e242b209742b76b5101575f89aaece98d5a6b (diff)
downloadcherrypy-git-54b676cc97ed3c5d57f69cd77128c162b9630ac8.tar.gz
Revert "List all package data files explicitly"
This reverts commit edb6f63d7b6afa9a2fb488177de086f4b59983c3. This change was made in reaction to tests failing due to pypa/setuptools#1016. Better to wait for that issue to be resolved than to create new duplication in declaration of package files to later become stale.
Diffstat (limited to 'setup.py')
-rw-r--r--[-rwxr-xr-x]setup.py11
1 files changed, 0 insertions, 11 deletions
diff --git a/setup.py b/setup.py
index 8b3e3874..a3f4d987 100755..100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,3 @@
-#! /usr/bin/env python
-"""CherryPy package setuptools installer."""
-
import sys
import io
@@ -62,12 +59,6 @@ packages = [
'cherrypy.scaffold',
]
-package_data = {
- 'cherrypy': ['favicon.ico'],
- 'cherrypy.scaffold': ['static/made_with_cherrypy_small.png'],
- 'cherrypy.tutorial': ['tutorial.conf', 'favicon.ico', 'custom_error.html'],
-}
-
install_requires = [
'six',
'cheroot>=5.2.0',
@@ -125,7 +116,6 @@ setup_params = dict(
license=cp_license,
packages=packages,
entry_points={'console_scripts': ['cherryd = cherrypy.__main__:run']},
- package_data=package_data,
include_package_data=True,
install_requires=install_requires,
extras_require=extras_require,
@@ -137,7 +127,6 @@ setup_params = dict(
def main():
- """Package installation entry point."""
setuptools.setup(**setup_params)