summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2018-08-14 08:16:12 -0400
committerJason R. Coombs <jaraco@jaraco.com>2018-08-14 08:16:12 -0400
commit3ff123beec032c940a2a8c6ae85596e50026d465 (patch)
tree6752c44bde3e8f44549aaa8d4e9b43a088b66b79 /setup.py
parentd13adb6504404b6549df15b95de5991457453f08 (diff)
downloadcherrypy-git-3ff123beec032c940a2a8c6ae85596e50026d465.tar.gz
Rely on declarative configuration for long description.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 0 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index b5a96ed6..3e2baa3f 100755
--- a/setup.py
+++ b/setup.py
@@ -1,14 +1,9 @@
#! /usr/bin/env python
"""CherryPy package setuptools installer."""
-import io
-
import setuptools
-with io.open('README.rst', encoding='utf-8') as strm:
- long_desc = strm.read()
-
name = 'CherryPy'
repo_slug = 'cherrypy/{}'.format(name.lower())
repo_url = 'https://github.com/{}'.format(repo_slug)
@@ -20,7 +15,6 @@ params = dict(
description='Object-Oriented HTTP framework',
author='CherryPy Team',
author_email='team@cherrypy.org',
- long_description=long_desc,
classifiers=[
'Development Status :: 5 - Production/Stable',
'Environment :: Web Environment',