summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2018-09-01 12:36:55 -0400
committerJason R. Coombs <jaraco@jaraco.com>2018-09-01 12:36:55 -0400
commit63551ec1cd34029253fec04b97bb2f2fb76b4ead (patch)
tree63505ba183dd53897cb2fd67191a1596f378e43e /setup.py
parent545a4d24fb93c95507bba992ba8559c07b9adacd (diff)
downloadcherrypy-git-63551ec1cd34029253fec04b97bb2f2fb76b4ead.tar.gz
Drop support for Python 2.7. Fixes #1730.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 1 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index c2ee1d2d..9003ef72 100755
--- a/setup.py
+++ b/setup.py
@@ -24,8 +24,6 @@ params = dict(
'Framework :: CherryPy',
'License :: OSI Approved :: BSD License',
'Programming Language :: Python',
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
@@ -105,7 +103,7 @@ params = dict(
setup_requires=[
'setuptools_scm',
],
- python_requires='>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*',
+ python_requires='>=3.4',
)