summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2018-09-01 19:11:12 -0400
committerJason R. Coombs <jaraco@jaraco.com>2018-09-01 19:11:12 -0400
commit855b4341f6bc58dba692675817a09e82f8a4b287 (patch)
tree354fa54104008756b8399ee064dd8595eb9990f1 /setup.py
parent9d581ca62da9aa76f129b109b111076f279dfea7 (diff)
downloadcherrypy-git-855b4341f6bc58dba692675817a09e82f8a4b287.tar.gz
Drop support for Python 3.4v18.0.0
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 2 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 9003ef72..8a6b05b3 100755
--- a/setup.py
+++ b/setup.py
@@ -25,7 +25,6 @@ params = dict(
'License :: OSI Approved :: BSD License',
'Programming Language :: Python',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
@@ -96,14 +95,12 @@ params = dict(
'xcgi': ['flup'],
# https://docs.cherrypy.org/en/latest/advanced.html?highlight=windows#windows-console-events
- ':sys_platform == "win32" and python_version != "3.4"': ['pywin32'],
- ':sys_platform == "win32" and python_version == "3.4"':
- ['pypiwin32==219'],
+ ':sys_platform == "win32"': ['pywin32'],
},
setup_requires=[
'setuptools_scm',
],
- python_requires='>=3.4',
+ python_requires='>=3.5',
)