summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2017-11-17 22:49:23 -0500
committerGitHub <noreply@github.com>2017-11-17 22:49:23 -0500
commitc17be0f9c42bbce95b37688dd548e47114f4a136 (patch)
treec59f6ed4e6d5e665743e921a0c08e5ecc1bf668e /setup.py
parent90907912291e2d69e8ff2b9a3703b1bef9a62098 (diff)
parent380255baac47f15e60167c29f9c7b9a569bde1dd (diff)
downloadcherrypy-git-c17be0f9c42bbce95b37688dd548e47114f4a136.tar.gz
Merge pull request #1660 from cherrypy/feature/drop-py32v12.0.0
Drop support for Python 3.2 and 3.1.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 1 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index fa7a0492..4258ac3b 100755
--- a/setup.py
+++ b/setup.py
@@ -27,8 +27,6 @@ classifiers = [
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.1',
- 'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
@@ -118,7 +116,7 @@ setup_params = dict(
setup_requires=[
'setuptools_scm',
],
- python_requires='>=2.7,!=3.0.*',
+ python_requires='>=2.7,!=3.0.*,!=3.1.*,!=3.2.*',
)