summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Klimek <klimek@google.com>2012-07-06 05:48:52 +0000
committerManuel Klimek <klimek@google.com>2012-07-06 05:48:52 +0000
commit4da216637fa1ad4bdfd31bc265edb57ca35c2c12 (patch)
tree08b93fbc99de82a43b0bb4dba96dbfbf96abac45 /lib/CMakeLists.txt
parentea7eb071166c69e11bfda4f1d89d5c2b6bbcdca3 (diff)
downloadclang-4da216637fa1ad4bdfd31bc265edb57ca35c2c12.tar.gz
Adds the AST Matcher library, which provides a in-C++ DSL to express
matches on interesting parts of the AST, and callback mechanisms to act on them. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@159805 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index dfb9d61ff5..206c22818b 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -3,6 +3,7 @@ add_subdirectory(Basic)
add_subdirectory(Lex)
add_subdirectory(Parse)
add_subdirectory(AST)
+add_subdirectory(ASTMatchers)
add_subdirectory(Sema)
add_subdirectory(CodeGen)
add_subdirectory(Analysis)