summaryrefslogtreecommitdiff
path: root/test/CXX/temp/temp.spec/temp.explicit
diff options
context:
space:
mode:
authorJohn McCall <rjmccall@apple.com>2010-01-13 00:25:19 +0000
committerJohn McCall <rjmccall@apple.com>2010-01-13 00:25:19 +0000
commit220ccbf2c9ef97034cce80561f9f46c4f1f63bc7 (patch)
treeda32b58080875bda1362c4475b624aa9e388b346 /test/CXX/temp/temp.spec/temp.explicit
parentdd6bcc5f79666b9298d91a0a6ee7a0b537bde601 (diff)
downloadclang-220ccbf2c9ef97034cce80561f9f46c4f1f63bc7.tar.gz
Improve the reporting of non-viable overload candidates by noting the reason
why the candidate is non-viable. There's a lot we can do to improve this, but it's a good start. Further improvements should probably be integrated with the bad-initialization reporting routines. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@93277 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CXX/temp/temp.spec/temp.explicit')
-rw-r--r--test/CXX/temp/temp.spec/temp.explicit/p1.cpp2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/CXX/temp/temp.spec/temp.explicit/p1.cpp b/test/CXX/temp/temp.spec/temp.explicit/p1.cpp
index eb729ff676..b42633924e 100644
--- a/test/CXX/temp/temp.spec/temp.explicit/p1.cpp
+++ b/test/CXX/temp/temp.spec/temp.explicit/p1.cpp
@@ -48,7 +48,7 @@ template void X1<int>::f<>(int&, int*); // expected-note{{instantiation}}
// Explicitly instantiate members of a class template
struct Incomplete; // expected-note{{forward declaration}}
-struct NonDefaultConstructible { // expected-note{{candidate is the implicit copy constructor}}
+struct NonDefaultConstructible { // expected-note{{candidate constructor (the implicit copy constructor) not viable}}
NonDefaultConstructible(int); // expected-note{{candidate constructor}}
};