summaryrefslogtreecommitdiff
path: root/test/CXX/temp/temp.spec/temp.explicit
diff options
context:
space:
mode:
authorDouglas Gregor <dgregor@apple.com>2010-03-13 03:49:57 +0000
committerDouglas Gregor <dgregor@apple.com>2010-03-13 03:49:57 +0000
commit34fd284e0a6ea88b98d6e1183548264bab5b3702 (patch)
tree8e7c669be5f0d81236f4d52de0766d584723e8d1 /test/CXX/temp/temp.spec/temp.explicit
parent8721360da5cf3d5dfdc2fc2bf8d53a5f79307995 (diff)
downloadclang-34fd284e0a6ea88b98d6e1183548264bab5b3702.tar.gz
Re-revert the explicit template instantiation linkage patch. I am beginning to look incompetent
git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@98425 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CXX/temp/temp.spec/temp.explicit')
-rw-r--r--test/CXX/temp/temp.spec/temp.explicit/p1-emit.cpp4
1 files changed, 2 insertions, 2 deletions
diff --git a/test/CXX/temp/temp.spec/temp.explicit/p1-emit.cpp b/test/CXX/temp/temp.spec/temp.explicit/p1-emit.cpp
index d8f7b52145..70eb696418 100644
--- a/test/CXX/temp/temp.spec/temp.explicit/p1-emit.cpp
+++ b/test/CXX/temp/temp.spec/temp.explicit/p1-emit.cpp
@@ -12,10 +12,10 @@ T X<T>::member1;
template<typename T>
T X<T>::member2 = 17;
-// CHECK: @_ZN1XIiE7member1E = weak global i32 0
+// CHECK: @_ZN1XIiE7member1E = global i32 0
template int X<int>::member1;
-// CHECK: @_ZN1XIiE7member2E = weak global i32 17
+// CHECK: @_ZN1XIiE7member2E = global i32 17
template int X<int>::member2;
// For implicit instantiation of