summaryrefslogtreecommitdiff
path: root/test/CXX/temp/temp.spec/temp.explicit
diff options
context:
space:
mode:
authorDouglas Gregor <dgregor@apple.com>2010-03-13 03:14:19 +0000
committerDouglas Gregor <dgregor@apple.com>2010-03-13 03:14:19 +0000
commit8721360da5cf3d5dfdc2fc2bf8d53a5f79307995 (patch)
treed25823b30301c2ace8006611bea0bd93a9860569 /test/CXX/temp/temp.spec/temp.explicit
parent896b70ffc348f6e2c680b5fb5841984d5785b7b5 (diff)
downloadclang-8721360da5cf3d5dfdc2fc2bf8d53a5f79307995.tar.gz
Reinstate patch to turn explicit template instantiations into weak symbols
git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@98424 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CXX/temp/temp.spec/temp.explicit')
-rw-r--r--test/CXX/temp/temp.spec/temp.explicit/p1-emit.cpp4
1 files changed, 2 insertions, 2 deletions
diff --git a/test/CXX/temp/temp.spec/temp.explicit/p1-emit.cpp b/test/CXX/temp/temp.spec/temp.explicit/p1-emit.cpp
index 70eb696418..d8f7b52145 100644
--- a/test/CXX/temp/temp.spec/temp.explicit/p1-emit.cpp
+++ b/test/CXX/temp/temp.spec/temp.explicit/p1-emit.cpp
@@ -12,10 +12,10 @@ T X<T>::member1;
template<typename T>
T X<T>::member2 = 17;
-// CHECK: @_ZN1XIiE7member1E = global i32 0
+// CHECK: @_ZN1XIiE7member1E = weak global i32 0
template int X<int>::member1;
-// CHECK: @_ZN1XIiE7member2E = global i32 17
+// CHECK: @_ZN1XIiE7member2E = weak global i32 17
template int X<int>::member2;
// For implicit instantiation of