summaryrefslogtreecommitdiff
path: root/test/CXX/temp/temp.spec/temp.explicit
diff options
context:
space:
mode:
authorAndy Gibbs <andyg1001@hotmail.co.uk>2012-10-19 12:44:48 +0000
committerAndy Gibbs <andyg1001@hotmail.co.uk>2012-10-19 12:44:48 +0000
commit8e8fb3be5bd78f0564444eca02b404566a5f3b5d (patch)
treee97df0cbf59fac68bc269a2c75f0fa0090b3c481 /test/CXX/temp/temp.spec/temp.explicit
parent4a529d26d6ccfc9b3d11031f1256f4f87055c562 (diff)
downloadclang-8e8fb3be5bd78f0564444eca02b404566a5f3b5d.tar.gz
Prior to adding the new "expected-no-diagnostics" directive to VerifyDiagnosticConsumer, make the necessary adjustment to 580 test-cases which will henceforth require this new directive.
git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@166280 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CXX/temp/temp.spec/temp.explicit')
-rw-r--r--test/CXX/temp/temp.spec/temp.explicit/p11.cpp1
-rw-r--r--test/CXX/temp/temp.spec/temp.explicit/p3-0x.cpp1
-rw-r--r--test/CXX/temp/temp.spec/temp.explicit/p6.cpp1
3 files changed, 3 insertions, 0 deletions
diff --git a/test/CXX/temp/temp.spec/temp.explicit/p11.cpp b/test/CXX/temp/temp.spec/temp.explicit/p11.cpp
index 4ca5428315..5363cbe0ae 100644
--- a/test/CXX/temp/temp.spec/temp.explicit/p11.cpp
+++ b/test/CXX/temp/temp.spec/temp.explicit/p11.cpp
@@ -1,4 +1,5 @@
// RUN: %clang_cc1 -fsyntax-only -verify %s
+// expected-no-diagnostics
class X {
template <typename T> class Y {};
diff --git a/test/CXX/temp/temp.spec/temp.explicit/p3-0x.cpp b/test/CXX/temp/temp.spec/temp.explicit/p3-0x.cpp
index 1028830abe..146b6b5da8 100644
--- a/test/CXX/temp/temp.spec/temp.explicit/p3-0x.cpp
+++ b/test/CXX/temp/temp.spec/temp.explicit/p3-0x.cpp
@@ -1,4 +1,5 @@
// RUN: %clang_cc1 -std=c++11 -verify %s
+// expected-no-diagnostics
// If the name declared in the explicit instantiation is an
// unqualified name, the explicit instantiation shall appear in the
diff --git a/test/CXX/temp/temp.spec/temp.explicit/p6.cpp b/test/CXX/temp/temp.spec/temp.explicit/p6.cpp
index 13822725b5..0f5db21190 100644
--- a/test/CXX/temp/temp.spec/temp.explicit/p6.cpp
+++ b/test/CXX/temp/temp.spec/temp.explicit/p6.cpp
@@ -1,4 +1,5 @@
// RUN: %clang_cc1 -fsyntax-only -verify %s
+// expected-no-diagnostics
template<class T> class Array { /* ... */ };
template<class T> void sort(Array<T>& v) { }