summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBrian Jones <cbj@gnu.org>2002-02-08 04:42:28 +0000
committerBrian Jones <cbj@gnu.org>2002-02-08 04:42:28 +0000
commit3b70d2c0150b6490f883df6c02ecb54b723c1546 (patch)
treedcb726af1a52c99e4ad24d0e8e5e9baba630ecd6 /Makefile.am
parent114f79e48b0044fd4123a8a010e4197e5ee5f16f (diff)
downloadclasspath-3b70d2c0150b6490f883df6c02ecb54b723c1546.tar.gz
* configure.in: fixed broken make dist by moving some of the checks
out of an if statement wrapping functionality needed only for compiling JNI libraries, so unfortunately yes you probably must have a C compiler even if just compiling the Java source * Makefile.am: dist-hook to use $(distdir) instead of $(top_distdir) * native/gnu.java.awt.image: removed directory, needed file was already part of native/jni/gtk-peer/ directory and library. * resource/java/util/Makefile.am: updated properties files to include in distribution * resource/Makefile.am: include gnu in SUBDIRS * resource/gnu/Makefile.am: new file * resource/gnu/.cvsignore: ditto * resource/gnu/java/Makefile.am: ditto * resource/gnu/java/.cvsignore: ditto * resource/gnu/java/awt/Makefile.am: ditto * resource/gnu/java/awt/.cvsignore: ditto * resource/gnu/java/awt/peer/Makefile.am: ditto * resource/gnu/java/awt/peer/.cvsignore: ditto * resource/gnu/java/awt/peer/gtk/Makefile.am: ditto * resource/gnu/java/awt/peer/gtk/.cvsignore: ditto * configure.in: added above Makefiles to output
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index f358b79ff..292f5fccd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,10 +4,12 @@ SUBDIRS = lib native doc resource com gnu java vm javax
native: lib
-EXTRA_DIST = HACKING BUGS THANKYOU
+EXTRA_DIST = HACKING BUGS THANKYOU mauve-classpath
dist-hook:
- cp -R $(top_srcdir)/include $(top_distdir)
+ -mkdir $(distdir)/include
+ cp $(top_srcdir)/include/*.in $(distdir)/include
+ cp $(top_srcdir)/include/*.h $(distdir)/include
ChangeLog:
cvs2cl.pl -b --gmt --log-opts "-d'1998-06-30< now'" --window 7200 --usermap ChangeLog.usermap --ignore ChangeLog --fsf