summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Koch <konqueror@gmx.de>2004-05-21 07:25:39 +0000
committerMichael Koch <konqueror@gmx.de>2004-05-21 07:25:39 +0000
commitf95a098686627f978b8409419518e0dbd10b3622 (patch)
treeb8ebdfa586c538c993871238f0c6cc9addac55fc /configure.ac
parentcb31b41f9698c998acd65b61050bc374d74b3fec (diff)
downloadclasspath-f95a098686627f978b8409419518e0dbd10b3622.tar.gz
2004-05-21 Michael Koch <konqueror@gmx.de>
* acinclude.m4 (CLASSPATH_WITH_INCLUDEDIR): Removed. * configure.ac (EXTRA_INCLUDES): Removed. (AM_CPPFLAGS): New variable to store needed includes. * native/fdlibm/Makefile.am (INCLUDES): Removed. * native/jni/classpath/Makefile.am (INCLUDES): Removed. * native/jni/gtk-peer/Makefile.am: Use libgtkpeer_la_CPPFLAGS instead of INCLUDES. * native/jni/java-awt/Makefile.am (INCLUDES): Removed. * native/jni/java-io/Makefile.am (INCLUDES): Removed. * native/jni/java-lang/Makefile.am: Use libjavalang_la_CFLAGS and libjavalangreflect_la_CFLAGS instead of INCLUDES. * native/jni/java-net/Makefile.am (INCLUDES): Removed. * native/jni/java-nio/Makefile.am (INCLUDES): Removed. * native/jni/java-util/Makefile.am (INCLUDES): Removed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index c79735ec1..05f3872bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -143,12 +143,12 @@ fi
CLASSPATH_WITH_JAVAH
-CLASSPATH_WITH_INCLUDEDIR
-
dnl -----------------------------------------------------------
dnl Add the include files for the native abstraction layer.
dnl -----------------------------------------------------------
-EXTRA_INCLUDES="${EXTRA_INCLUDES} -I\$(top_srcdir)/native/target/Linux -I\$(top_srcdir)/native/target/generic"
+AM_CPPFLAGS="-I\$(top_srcdir)/include -I\$(top_srcdir)/native/jni/classpath"
+AM_CPPFLAGS="$AM_CPPFLAGS -I\$(top_srcdir)/native/target/Linux -I\$(top_srcdir)/native/target/generic"
+AC_SUBST(AM_CPPFLAGS)
dnl -----------------------------------------------------------
if test "x${COMPILE_JNI}" = xyes; then