summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndreas Tobler <a.tobler@schweiz.org>2006-08-31 19:56:03 +0000
committerAndreas Tobler <a.tobler@schweiz.org>2006-08-31 19:56:03 +0000
commit090a4a2615dd9ce6c1dc97510ed008affd88c29f (patch)
tree9c5cc360eba5f019eeec12343bb8bd1dca6cf924 /configure.ac
parent99e04c1a6472484960e3e2b7ad44b3bb25db8cbf (diff)
downloadclasspath-090a4a2615dd9ce6c1dc97510ed008affd88c29f.tar.gz
2006-08-31 Andreas Tobler <a.tobler@schweiz.ch>
* configure.ac: Add check for gethostbyname_r. Add check for MSG_NOSIGNAL and SO_NOSIGPIPE. * native/jni/native-lib/cpnet.c (SOCKET_NOSIGNAL): Define SOCKET_NOSIGNAL according to the configure check. (cpnet_send): Use SOCKET_NOSIGNAL. (cpnet_sendTo): Likewise. (cpnet_getHostByName): Use gethostbyname in case gethostbyname_r is not defined. * native/jni/native-lib/cpio.c: Define O_SYNC and O_DSYNC in case they are not available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 23 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e222ee110..99a3fc5fe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -368,7 +368,7 @@ if test "x${COMPILE_JNI}" = xyes; then
lseek fstat read write htonl memset htons connect \
getsockname getpeername bind listen accept \
recvfrom send sendto setsockopt getsockopt time mktime \
- localtime_r \
+ gethostbyname_r localtime_r \
strerror_r \
fcntl \
mmap munmap mincore msync madvise getpagesize sysconf \
@@ -550,6 +550,28 @@ if test "x${COMPILE_JNI}" = xyes; then
AC_SUBST(QT_CFLAGS)
AC_SUBST(QT_LIBS)
fi
+ dnl **********************************************************************
+ dnl Check for MSG_NOSIGNAL
+ dnl **********************************************************************
+ AC_MSG_CHECKING(for MSG_NOSIGNAL)
+ AC_TRY_COMPILE([#include <sys/socket.h>],
+ [ int f = MSG_NOSIGNAL; ],
+ [ AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_MSG_NOSIGNAL, 1,
+ [Define this symbol if you have MSG_NOSIGNAL]) ],
+ [ AC_MSG_RESULT(no)]
+ )
+ dnl **********************************************************************
+ dnl Check for SO_NOSIGPIPE (Darwin equivalent for MSG_NOSIGNAL)
+ dnl **********************************************************************
+ AC_MSG_CHECKING(for SO_NOSIGPIPE )
+ AC_TRY_COMPILE([#include <sys/socket.h>],
+ [ int f = SO_NOSIGPIPE; ],
+ [ AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_SO_NOSIGPIPE, 1,
+ [Define this symbol if you have SO_NOSIGPIPE]) ],
+ [ AC_MSG_RESULT(no)]
+ )
dnl Check for plugin support headers and libraries.
if test "x${COMPILE_PLUGIN}" = xyes; then