summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCasey Marshall <csm@gnu.org>2006-09-23 01:45:29 +0000
committerCasey Marshall <csm@gnu.org>2006-09-23 01:45:29 +0000
commit2c639ca6b5413fc46644bc36f14ceaff3b5dd740 (patch)
tree709f0cb86882aa1e9a42e411ee12f3be107d69a0 /configure.ac
parent38301647337533dbfd8655db4961ad487f8cfccf (diff)
downloadclasspath-2c639ca6b5413fc46644bc36f14ceaff3b5dd740.tar.gz
2006-09-22 Casey Marshall <csm@gnu.org>
* configure.ac (AC_CHECK_FUNCS): check for `readdir_r.' * native/jni/java-io/java_io_VMFile.c (Java_java_io_VMFile_list): allocate `filename,' and handle changes to `cpio_readDir.' * native/jni/native-lib/cpio.c (cpio_readDir): use `readdir_r' if available; copy the filename into the destination buffer; return an error code if readdir returns NULL, but errno is 0. * native/jni/native-lib/cpio.h (cpio_readDir): change second parameter to `const char *.'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 22507ee3c..1805eb8f8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -375,7 +375,8 @@ if test "x${COMPILE_JNI}" = xyes; then
mmap munmap mincore msync madvise getpagesize sysconf \
lstat readlink \
inet_aton inet_addr inet_pton \
- getifaddrs kqueue kevent epoll_create])
+ getifaddrs kqueue kevent epoll_create \
+ readdir_r ])
LIBMAGIC=
AC_CHECK_LIB(magic, magic_open, LIBMAGIC=-lmagic)
@@ -938,4 +939,4 @@ AC_OUTPUT
cat ${srcdir}/lib/standard.omit.in > lib/standard.omit
if test x$use_escher != xtrue; then
echo gnu/java/awt/peer/x/.*java$ >> lib/standard.omit
-fi
+fi \ No newline at end of file