summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Fitzsimmons <fitzsim@redhat.com>2006-06-02 16:01:33 +0000
committerThomas Fitzsimmons <fitzsim@redhat.com>2006-06-02 16:01:33 +0000
commit50993cec6b2d786eeef7213449c1f99100c21607 (patch)
tree1acb4effbe1a3adcffbc376f6f658f5bf45e02a5 /configure.ac
parent346d414b9d4cbb8bbb03736f47eaf118b3f91328 (diff)
downloadclasspath-50993cec6b2d786eeef7213449c1f99100c21607.tar.gz
2006-06-01 Miriam Schuster <schmir11@web.de>
* Makefile.am: Add fallback if "mozilla-plugin" is not available. Fallbacks used: "firefox-plugin" and "xulrunner-plugin".
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 31bc1e94c..7d1288a16 100644
--- a/configure.ac
+++ b/configure.ac
@@ -472,7 +472,13 @@ if test "x${COMPILE_JNI}" = xyes; then
dnl Check for plugin support headers and libraries.
if test "x${COMPILE_PLUGIN}" = xyes; then
- PKG_CHECK_MODULES(MOZILLA, mozilla-plugin)
+ PKG_CHECK_MODULES(MOZILLA, mozilla-plugin, [MOZILLA_FOUND=yes], [MOZILLA_FOUND=no])
+ if test "x${MOZILLA_FOUND}" = xno; then
+ PKG_CHECK_MODULES(MOZILLA, firefox-plugin, [MOZILLA_FOUND=yes], [MOZILLA_FOUND=no])
+ fi
+ if test "x${MOZILLA_FOUND}" = xno; then
+ PKG_CHECK_MODULES(MOZILLA, xulrunner-plugin, [MOZILLA_FOUND=yes], [MOZILLA_FOUND=no])
+ fi
PKG_CHECK_MODULES(GLIB, glib-2.0)
AC_SUBST(MOZILLA_CFLAGS)