summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMark Wielaard <mark@klomp.org>2006-08-02 23:28:12 +0000
committerMark Wielaard <mark@klomp.org>2006-08-02 23:28:12 +0000
commita70104a340717ff09a0efe811c4f9306fdea1f66 (patch)
tree3fc9389412bd94ce104142372cebcecf35c37f3d /configure.ac
parent8f065a9a2887bc1e1633a733a36370129abcefe2 (diff)
downloadclasspath-a70104a340717ff09a0efe811c4f9306fdea1f66.tar.gz
PR 28535
* configure.ac (gconf-peer): Check for gdk-2.0. * native/jni/gconf-peer/Makefile.am (AM_LDFLAGS): Use GDK_LIBS. (AM_CFLAGS): Use GDK_CFLAGS.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c82750399..4fa1e4948 100644
--- a/configure.ac
+++ b/configure.ac
@@ -478,6 +478,10 @@ if test "x${COMPILE_JNI}" = xyes; then
PKG_CHECK_MODULES(GCONF, gconf-2.0 >= 2.11.2)
AC_SUBST(GCONF_CFLAGS)
AC_SUBST(GCONF_LIBS)
+ dnl we also need gdk for locking
+ PKG_CHECK_MODULES(GDK, gdk-2.0 >= 2.8)
+ AC_SUBST(GDK_CFLAGS)
+ AC_SUBST(GDK_LIBS)
dnl check if the config value was given form the command line,
dnl if not, overwrite the default if we have the gconf backend
dnl compiled in