summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrew John Hughes <gnu_andrew@member.fsf.org>2008-02-22 03:06:03 +0000
committerAndrew John Hughes <gnu_andrew@member.fsf.org>2008-02-22 03:06:03 +0000
commit32e4572f5dd85f69111ccebb1f6069137e1c660c (patch)
tree6a8e26a754111c767fc448f118830437b4bb76a9 /configure.ac
parentefe66a0e796306f46f1f863aec10fcfae07ff467 (diff)
downloadclasspath-32e4572f5dd85f69111ccebb1f6069137e1c660c.tar.gz
2008-02-22 Andrew John Hughes <gnu_andrew@member.fsf.org>
PR classpath/33751: * configure.ac: Don't check for readdir_r. * native/jni/native-lib/cpio.c: (cpio_readDir): Remove use of readdir_r, zero errno before starting and always leave a \0 at the end after strncpy. * vm/reference/java/io/VMFile.java: (list(String)): Make synchronized.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 787c8842a..a46ccbf29 100644
--- a/configure.ac
+++ b/configure.ac
@@ -401,7 +401,7 @@ if test "x${COMPILE_JNI}" = xyes; then
lstat readlink \
inet_aton inet_addr inet_pton \
getifaddrs kqueue kevent epoll_create \
- readdir_r getloadavg])
+ getloadavg])
LIBMAGIC=
AC_CHECK_LIB(magic, magic_open, LIBMAGIC=-lmagic)