summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRoman Kennke <roman@kennke.org>2007-09-11 09:48:49 +0000
committerRoman Kennke <roman@kennke.org>2007-09-11 09:48:49 +0000
commit82bdf5ea5b628a257f3103e7505c963f9d2f97db (patch)
tree37c51f8e01df9773547d1090214ab7b5090dd85d /configure.ac
parent727d023cd74fec43257a4b753f576094b3379757 (diff)
downloadclasspath-82bdf5ea5b628a257f3103e7505c963f9d2f97db.tar.gz
2007-09-11 Roman Kennke <roman@kennke.org>
* native/jni/gtk-peer/gnu_java_awt_peer_gtk_CairoGraphics2D.c Removed unused includes. * native/jni/gtk-peer/gnu_java_awt_peer_gtk_CairoSurface.c Removed unused includes. * native/jni/gtk-peer/gnu_java_awt_peer_gtk_ComponentGraphics.c Removed unusued excludes. Put Xrender includes in HAVE_XRENDER conditional. (flush): Use gdk_display_flush() instead of XFlush(). (initState): Use GDK/Cairo functions to get cairo_t object. (initFromVolatile): Likewise. * native/jni/gtk-peer/gnu_java_awt_peer_gtk_ComponentGraphicsCopy.c Removed unused includes. * native/jni/gtk-peer/gnu_java_awt_peer_gtk_GdkRobotPeer.c Use HAVE_XTEST conditionals for code that uses XTest. * native/jni/gtk-peer/gnu_java_awt_peer_gtk_GtkImage.c Removed unused includes. * native/jni/gtk-peer/gnu_java_awt_peer_gtk_GtkToolkit.c Removed unused includes. * native/jni/gtk-peer/gnu_java_awt_peer_gtk_GtkVolatileImage.c Removed unused includes. * native/jni/gtk-peer/gnu_java_awt_peer_gtk_GtkWindowPeer.c Removed unused includes. Rewrote frame-extents code to use gdk_window_get_frame_extents() rather than the X window properties directly. * include/gnu_java_awt_peer_gtk_ComponentGraphics.h (initFromVolatile): Removed width and height parameters. * gnu/java/awt/peer/gtk/ComponentGraphics.java (initFromVolatile): Remove width and height parameters. * gnu/java/awt/peer/gtk/VolatileImageGraphics.java (VolatileImageGraphics): Use initFromVolatile without width and height. * configure.ac: Check for presence of XTest, and define HAVE_XTEST accordingly.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index aa1c989b7..84d1918c8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -485,11 +485,13 @@ if test "x${COMPILE_JNI}" = xyes; then
if test "$no_x" = yes; then
AC_MSG_ERROR([GTK+ peers requested but no X library available])
fi
- dnl We explicitly want the XTest Extension for Robot support.
+ dnl Check if we can link against the XTest library and set
+ dnl HAVE_XTEST accordingly.
AC_CHECK_LIB([Xtst], [XTestQueryExtension],
- [XTEST_LIBS="$XTEST_LIBS -lX11 -lXtst"],
- [AC_MSG_ERROR([libXtst NOT found, required for GdkRobot])],
- [${X_LIBS}])
+ [AC_DEFINE(HAVE_XTEST, 1, [Define to 1 if you have libXtst.])[XTEST_LIBS="$XTEST_LIBS -X11 -lXtst"]],
+ [true],
+ [${X_LIBS}])
+
PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.8 gthread-2.0 >= 2.2 gdk-pixbuf-2.0)
PKG_CHECK_MODULES(FREETYPE2, freetype2)