summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTom Tromey <tromey@redhat.com>2006-07-28 15:22:29 +0000
committerTom Tromey <tromey@redhat.com>2006-07-28 15:22:29 +0000
commit1df72fb152a2ed319bfe12ae18c3a558e3b12d53 (patch)
treea50a023bd8c959cb589a5a687269c700b1392da3 /configure.ac
parentb169e48309762b3f1d3f2a26976968a581e5c7bf (diff)
downloadclasspath-1df72fb152a2ed319bfe12ae18c3a558e3b12d53.tar.gz
* NEWS: Updated.
* .classpath: Updated. * tools/.cvsignore: Added gjavah. * tools/Makefile.am ($(TOOLS_ZIP)): Only build javah if ASM is available. (GLIBJ_CLASSPATH): Add asm jar. (javah): New macro. (bin_PROGRAMS, bin_SCRIPTS): Added $(javah). (gjavah_SOURCES, gjavah_CFLAGS, gjavah_LDFLAGS): new macros. * tools/gjavah.in: New file. * configure.ac: Added --with-asm option. * tools/gnu/classpath/tools/javah/ClassWrapper.java: New file. * tools/gnu/classpath/tools/javah/CniIncludePrinter.java: Likewise. * tools/gnu/classpath/tools/javah/CniPrintStream.java: Likewise. * tools/gnu/classpath/tools/javah/CniStubPrinter.java: Likewise. * tools/gnu/classpath/tools/javah/FieldHelper.java: Likewise. * tools/gnu/classpath/tools/javah/JniHelper.java: Likewise. * tools/gnu/classpath/tools/javah/JniIncludePrinter.java: Likewise. * tools/gnu/classpath/tools/javah/JniStubPrinter.java: Likewise. * tools/gnu/classpath/tools/javah/Keywords.java: Likewise. * tools/gnu/classpath/tools/javah/Main.java: Likewise. * tools/gnu/classpath/tools/javah/MethodHelper.java: Likewise. * tools/gnu/classpath/tools/javah/PackageWrapper.java: Likewise. * tools/gnu/classpath/tools/javah/PathOptionGroup.java: Likewise. * tools/gnu/classpath/tools/javah/Printer.java: Likewise. * tools/gnu/classpath/tools/javah/Text.java: Likewise.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 32 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 14911bad3..0461faa62 100644
--- a/configure.ac
+++ b/configure.ac
@@ -730,18 +730,43 @@ case "$with_escher" in
use_escher=false
;;
"yes")
- AC_MSG_ERROR([Please suply an absolute path to Escher library])
+ AC_MSG_ERROR([Please supply an absolute path to Escher library])
;;
*)
use_escher=true
PATH_TO_ESCHER=$with_escher
;;
-esac;
+esac
AM_CONDITIONAL(USE_ESCHER, test x$use_escher = xtrue)
AC_SUBST(PATH_TO_ESCHER)
dnl -----------------------------------------------------------
+dnl Build javah using ASM library
+dnl -----------------------------------------------------------
+AC_ARG_WITH([asm],
+ AS_HELP_STRING([--with-asm=ABS.PATH],
+ [specify path to ASM jar for javah]))
+case "$with_asm" in
+"")
+ use_asm=false
+ ;;
+"no")
+ use_asm=false
+ ;;
+"yes")
+ AC_MSG_ERROR([Please supply an absolute path to ASM jar])
+ ;;
+*)
+ use_asm=true
+ PATH_TO_ASM=$with_asm
+ ;;
+esac
+
+AM_CONDITIONAL(USE_ASM, test x$use_asm = xtrue)
+AC_SUBST(PATH_TO_ASM)
+
+dnl -----------------------------------------------------------
dnl Check if local socket support should be included.
dnl -----------------------------------------------------------
AC_ARG_ENABLE([local-sockets],
@@ -828,6 +853,11 @@ AC_CONFIG_COMMANDS([gkeytool],[chmod 755 tools/gkeytool])
AC_CONFIG_COMMANDS([gjar],[chmod 755 tools/gjar])
AC_CONFIG_COMMANDS([gnative2ascii],[chmod 755 tools/gnative2ascii])
AC_CONFIG_COMMANDS([gserialver],[chmod 755 tools/gserialver])
+
+ if test "$use_asm" = true; then
+ AC_CONFIG_FILES([tools/gjavah])
+ AC_CONFIG_COMMANDS([gjavah], [chmod 755 tools/gjavah])
+ fi
fi
AC_CONFIG_COMMANDS([gen-classlist],[chmod 755 lib/gen-classlist.sh])
@@ -839,4 +869,3 @@ cat ${srcdir}/lib/standard.omit.in > lib/standard.omit
if test x$use_escher != xtrue; then
echo gnu/java/awt/peer/x/.*java$ >> lib/standard.omit
fi
-